My campaigns don't send, they're stuck in "Pending-Sending" status

Samuel Osoba

New Member
I happen to be in this loop now, trying to figure out my reasons as to why the campaigns stopped sending, this has never happened in a long time:

- My crons are still intact at 15mins intervals and higher.
- My SES service is still running.

I don't even know where to look at anymore, but I have been having an issue find the application error log file, what is the path to finding the app log files, I believe there should be logs there to narrow down the problem ... ???

This is urgent.
 

Lana Cortelezzi

New Member
Hallo, I`m also in pending sending.

Shared hosting Timeweb, Amazon SES, draft mails sends well but not autoresponders.

Got right path to php, a freelancer set me cron jobs and I got regular reports like
---------
Yii command runner (based on Yii v1.1.17)
Usage: /home/l/.../....com/public_html/mailwizz/apps/console/console.php <command-name> [parameters...]
The following commands are available:
- ...
- sendcampaigns
- sendtransactionalemails
- update
------
So I cron is working or not?

As you noticed:
Changed premissions for console.php from 600 to 644
Changed max campaigns to 100

What should I do?
 

twisted1919

Administrator
Staff member
Got right path to php, a freelancer set me cron jobs and I got regular reports like
- ...
- sendcampaigns
- sendtransactionalemails
- update
------
This is wrong, it means that the freelancer guy didn't properly add the cron jobs, can you post a screenshot with the way the cron jobs are setup?
 

Lana Cortelezzi

New Member
Hallo,
Yes I have found that he tried to make cron through hosting crontab and asked him to make it through ssh.
When he said he did it I got my autoresponder mail (thats how I test) but I could not repeat my success. Thats weird =(

SES works.
Cron screenshot that freelancer sent - http://prntscr.com/an9n44

What should I do?
 

umoh

New Member
Scheduled emails for today (4/26/16) @ TODAYS DATE/TIME 4/26/16, 9:00 AM. The time has long passed, still showing "Pending-sending"
BUT:
Scheduled emails for today (4/26/16) @ YESTERDAY DATE/TIME 4/25/16, 9:10 AM - The emails has Sent (100%) today at same time
MY QUESTION:
1. The emails scheduled at current time never gets delivered forever. WHY?
2. What caused the difference in delivery time and recommended solution. NOTE: my cron job is well set
 

Aivaras

New Member
Hello,
My created campaigns are stuck on Pending-sending. I did configure cron jobs like server provider told to. But Mail seems is not getting delivered. Adding cron jobs how they look. Any suggestions?
 

Attachments

frm.mwz

Well-Known Member
Hello,
My created campaigns are stuck on Pending-sending. I did configure cron jobs like server provider told to. But Mail seems is not getting delivered. Adding cron jobs how they look. Any suggestions?
The crons in the pic you posted cannot work, not only are they all the same, but they don't do anything, see from the install cron hints and in-app cron info and here in the thread how it should be.

Read, and the force will be with you!

Another thread with cron info:
https://forum.mailwizz.com/threads/what-are-the-cron-jobs-that-i-have-to-add.12/

...a few tips:
#1 read/understand this/other whole thread
#2 find your 'php-cli' with # whereis php-cli
#3 see /backend/misc/cron-jobs-list or go menu 'miscellaneous'->'cron job list'

post/ask specifics ;)
 
Last edited:

Aivaras

New Member
The crons in the pic you posted cannot work, not only are they all the same, but they don't do anything, see from the install cron hints and in-app cron info and here in the thread how it should be.

Read, and the force will be with you!

Another thread with cron info:
https://forum.mailwizz.com/threads/what-are-the-cron-jobs-that-i-have-to-add.12/

...a few tips:
#1 read/understand this/other whole thread
#2 find your 'php-cli' with # whereis php-cli
#3 see /backend/misc/cron-jobs-list or go menu 'miscellaneous'->'cron job list'

post/ask specifics ;)
Lol :D Thank for the reply! I tried to enter the following cron from 'cron job list' but it seem not to work either. Just found out that panel is configured out only understand url path (consultant wasn't clear). Yea, I red those posts, but sadly cant find solution.
Also there is one more problem. Program does not let me create SMTP delivery servers. I get this error (
  • The server type smtp requires following functions to be active on your host: proc_open or popen!
).Maybe it ha some thing to do with this? Also I am using shared server so cant accesses command line.
 

Attachments

frm.mwz

Well-Known Member
Ask your shared server host if they allow outside smtp/3rd party smtp/relay from your account out.
If not, use webhooks/api calls to delivery servers, see mailwizz config.
 

Aivaras

New Member
Have you added cron jobs through direct admin panel? I tried it but seems not working. I mean should I add full string or just home url? My provider does not really help with this.
Added crone jobs how they look like from api.
 

Attachments

Last edited:

twisted1919

Administrator
Staff member
@Aivaras - the cron jobs that you have to add, are linux cron jobs, that is you need to exter the binary that executes a file, that is in this case the binary is /usr/bin/php and the file is /some/absolute/path/to/apps/console/console.php send-campaigns >/dev/null 2&1.
From the screenshot above, seems your provider only allows web crons, which do not work with mailwizz.
Also, the other error is related to proc_open and/or popen, two php functions that your hosting is blocking for no reason.
My advice is to simply change host, it's not acceptable to have this limits in 2016 where you have so many alternatives.
 

cma01

New Member
The crons in the pic you posted cannot work, not only are they all the same, but they don't do anything, see from the install cron hints and in-app cron info and here in the thread how it should be.

Read, and the force will be with you!

Another thread with cron info:
https://forum.mailwizz.com/threads/what-are-the-cron-jobs-that-i-have-to-add.12/

...a few tips:
#1 read/understand this/other whole thread
#2 find your 'php-cli' with # whereis php-cli
#3 see /backend/misc/cron-jobs-list or go menu 'miscellaneous'->'cron job list'

post/ask specifics ;)
Thanks for that. I've been trying to figure this out for awhile. It was in a different directory. Once I updated the cron job the pending-sending campaign went immediately.
 

icactive

New Member
I got the same issue.
After a week waiting, the campaign still Sending (0%), test email worked just fine.
i've checked all things. (servers delivery etc.) it looks all good to me. not sure why this happens. please advice.
thanks
 

frm.mwz

Well-Known Member
I got the same issue.
After a week waiting, the campaign still Sending (0%), test email worked just fine.
i've checked all things. (servers delivery etc.) it looks all good to me. not sure why this happens. please advice.
thanks
Does each delivery server really send? (test msg ok?)
Do your crons really fire? (check on command line?)
Is your campaign really unpaused? (used new test campaign?)
(basically, eliminate any/all errors)
 

icactive

New Member
hi thanks for the respond.
1. Yes the test email works good.
2. I'm not really sure how to run the cronjob on SSH, I'm using my hosting panel like this https://imgur.com/92DsPCL
3. I believe the campaign setting is good, since i've done many campaigns in the past.

thanks
 
Top