My campaigns don't send, they're stuck in "Pending-Sending" status

frm.mwz

Well-Known Member
hi thanks for the respond.
1. Yes the test email works good.
2. I'm not really sure how to run the cronjob on SSH, I'm using my hosting panel like this https://imgur.com/92DsPCL
3. I believe the campaign setting is good, since i've done many campaigns in the past.

thanks

Can you just delete the hanging campaign and create a new one, and then see if that works, or is it that all new ones are not going out?

Re #2, just (see above in the thread, find your php-cli and) use the cron command in the cli. You find the cron command within mwz or in your cron tab.
 

icactive

New Member
I think i know now what the problem is, the cron was pointed to older path. I have moved the application to /app/ folder, and now updated the cron again, hope it will work now.
thank you
 

frm.mwz

Well-Known Member
I think i know now what the problem is, the cron was pointed to older path. I have moved the application to /app/ folder, and now updated the cron again, hope it will work now.
thank you
Happy to help & happy if u like it ;)
 

kosir

Member
Pfiju.. Just made 100 autoresponders for a customer and all were stuck at "Pending-sending". The cron limit was the reason and once I set it higher all is well :)

Since I reserved 3h to solve this, now I have nothing to do. Luckily I searched the forum before going in any deeper.
 

twisted1919

Administrator
Staff member
@kosir - new versions of mailwizz have a switch and if you turn it on, mailwizz will automatically detect the right number of campaigns it has to run.
 

hipl

New Member
Hi Guys

I have same issues sending my campaigns it just get struck and pending sending/ sending but it actually does not send
here some of the info i am getting while running the commands in forums
which php
reply - /usr/bin/php
/usr/bin/php -v
reply
PHP 5.6.36 (cli) (built: Apr 25 2018 10:11:47)
Copyright (c) 1997-2016 The PHP Group
/usr/local/php5/bin/php-cli -v
when i run this i get to see the message as -bash: /usr/local/php5/bin/php-cli: No such file or directory

for your info application in installed under http://abc.com/mailer/
 
Top