My campaigns don't send, they're stuck in "Pending-Sending" status

Rob

Active Member
Can you post your cron jobs list from your server and what they are in the Backend > Miscellaneous > Cron Job List
 

Rob

Active Member
I assume you had this working before?

Some people have found that cpanel can mess with your cron jobs if an update of somekind has occured. Check your cron logs to see if they are firing, then try the send cron job without /usr/bin/php -q faling that, seeing as you have CLI access try setting your cron jobs up using that and "crontab -e"

Also check your delivery & application logs in the backend.
 

Garret

Member
i am frustrated beyond recognition to the point i want to kick my monitor screen in. I've tried sending from 3 different servers including local. Run the cron manually in command line with no errors. And nothing is sent. Clients are pissed because their weekend sale went to shit because emails didn't go out.
Okay, so the first question is were these running before?
 

hasan

New Member
Hello,

on my server have this path
/usr/local/php56/bin/php
so how and where to change cron path on mailwiz to make cron work?

Please send me step to make change.

Thanks
 

hasan

New Member
Hello twisted1919,
here are response i got after i run the command on my vps server:- /usr/bin/php -v

PHP 5.4.36 (cli) (built: Jan 8 2015 13:14:21)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
with XCache v3.0.1, Copyright (c) 2005-2013, by mOo
with XCache Optimizer v3.0.1, Copyright (c) 2005-2013, by mOo
with XCache Cacher v3.0.1, Copyright (c) 2005-2013, by mOo
with XCache Coverager v3.0.1, Copyright (c) 2005-2013, by mOo

so now i need to know what and where i have to make changes to make work cron?
plz advice.

Thanks
 

twisted1919

Administrator
Staff member
@hasan - if you run /usr/local/php56/bin/php -v what does it say?
Also, what are your current cron jobs, attach a screenshot.
Thanks.
 

hasan

New Member
Hello twisted1919,

Here is what comes when i run /usr/local/php56/bin/php -v
Code:
[ps430133]$ /usr/local/php56/bin/php -v
PHP 5.6.4 (cli) (built: Jan  8 2015 14:19:31)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2014 Zend Technologies
    with XCache v3.2.0, Copyright (c) 2005-2014, by mOo
    with XCache Optimizer v3.2.0, Copyright (c) 2005-2014, by mOo
    with XCache Cacher v3.2.0, Copyright (c) 2005-2014, by mOo
    with XCache Coverager v3.2.0, Copyright (c) 2005-2014, by mOo

below is my crons details which i have setup on my vps server.

Campaigns sender, runs each minute.

/usr/local/php56/bin/php -q /home/myfolder/mydomainname.com/myfolder/apps/console/console.php send-campaigns >/dev/null 2>&1

Transactional email sender, runs once at 2 minutes.

/usr/local/php56/bin/php -q /home/myfolder/mydomainname.com/myfolder/apps/console/console.php send-transactional-emails >/dev/null 2>&1

Bounce handler, runs once at 10 minutes.

/usr/local/php56/bin/php -q /home/myfolder/mydomainname.com/myfolder/apps/console/console.php bounce-handler >/dev/null 2>&1

Feedback loop handler, runs once at 20 minutes.

/usr/local/php56/bin/php -q /home/myfolder/mydomainname.com/myfolder/apps/console/console.php feedback-loop-handler >/dev/null 2>&1

Delivery/Bounce processor, runs once at 3 minutes.

/usr/local/php56/bin/php -q /home/myfolder/mydomainname.com/myfolder/apps/console/console.php process-delivery-and-bounce-log >/dev/null 2>&1

Daily cleaner, runs once a day.

/usr/local/php56/bin/php -q /home/myfolder/mydomainname.com/myfolder/apps/console/console.php daily >/dev/null 2>&1
Please advice, what i need to change to make this cron work.

Thanks for help
 
Last edited by a moderator:

twisted1919

Administrator
Staff member
@hasan - it all looks good, are you sure you have an active delivery server ?
If you take a look in backend -> misc -> application log, doesn\t you see messages related to missing servers ?
 

hasan

New Member
Hello,

Yes, i have 4 active and verified smtp server configured.
on log page showing so many logs, on top showing one
log as below:-
2015/06/05 08:16:25 [error] [exception.CHttpException.500] exception 'CHttpException' with message 'The email address is missing.' in /home/myfoldername/mydomainname.com/myfoldername/apps/backend/controllers/Delivery_serversController.php:269

If you can provide me any email where i can send you my admin access so
you can look setting once for me, i tried to configured all same as ur doc.

Please help

Thanks
 

Alteci

New Member
I'm having the same issue, I've checked the php binary, the cronjob file the console.php location, etc. still stuck in pending-sending. I just created a new converstation with twisted1919, please help.
 

Jamie Whittingham

Active Member
Im not facing this same issue.

Transactions emails = fine
campaign test emails = fine
password reset = fine
sending campaign (non parallel) = pending-sending

been like this for 2 days now and we only just noticed !!!

nothing in the cron with regards to errors, i run the cron manually and it just says nothing (which is normal)

anyone care to share the fix they were given by the dev as its now the weekend and he doesn't work weekends ...

cheers
 

Alteci

New Member
My issue was that the timezone settings was wrong, so it was sending, but three hours after I expected it to. Changing the timezone fixed my issue.
 

Diego

Member
Hi Guys,

Please also try

Backend -> Settings -> Cron

and set it to max 100 campaigns (then if it works, you can reduce it to 10/20 campaigns).

This fixed my problem (Campaigns Stuck in "Pending Sending") (thanks to twisted1919).

Comment: I see that this suggestion has been now added to the thread
but i'm mentioning here once again because it's another important thing to try.
 

Fatou

New Member
Yes I am having the same problem. My campaign got stock at Pending-Sending. I just found Diego post here and I went to backend, setting, cron and change campaign at once to 100. I'll give an update if it fixed my problem or not as my next mail is scheduled for tomorrow morning.
Thanks Diego and twisted1919.
 
Top