pnnetbuy

New Member
I have a support ticket open on this, but figured I'd bring it up here in case of any experienced users have any ideas. If I get an answer from the ticket first, I'll publish it here.

I can't set a tracking link. The cname is set and even loads my MW installation in a browser.

I moved the domain off of cloudflare and am now just using the registrar's (namecheap) DNS (as I found CF could have been the problem).

I keep getting this error:

Cannot find a valid CNAME record for tracking.mytrackingdomain.com! Remember, the CNAME of tracking.mytrackingdomain.com must point to sub.mailwizzinstalldomain.com!

What I'm missing?
 

mfadal

New Member
Hello,

I use a very similar setup which works for me, so i am a little curious why it would not work for you.

A few questions:
(*) When you run a ping against your CNAME, does it return the correct IP (if via NameCheap)? If you use CF and using proxies to hide, does it return the proxy IP?
(*) In my setup, i only use an A record for the actual domain IP and then a CNAME record, these are the only 2 records in my domains.

My experience with Cloudfare & Tracking links:
(1) At times, it usually takes approx 24 hours for this to be completely resolved, maybe longer depending on where you are located.
(2) If you have waited for more than 24 hours and still not resolved, you need to look a little deeper in your DNS records,

my 2 cents, hope it helps
 

pnnetbuy

New Member
thanks for your help mfadal :)

I moved my domain off of cloudflare already and it still doesn't work.

I've tried using a cname, and then both a cname and A record to the IP.

In both cases it was pinging to the proper IP, and the url would load the MW login so it was definitely propagated.

Weird eh? I had literally 1000s of domains and many servers over the years and never had this kind of problem. So this is odd...

I'm using contabo for my VPS and everything else works fine... but maybe something there I dunno... Support has asked for my login via ticket so we'll see if they can figure it out. Of course if anyone else has ideas I'm game to hear.

Thanks again for your help! :)
 

pnnetbuy

New Member
So I said I would post the result here.

Support said that for some reason my server won't detect it but should work fine to set it to not verify and just move forward.

So if anyone else has the problem, I suggest turning off validation, set it, and then add yourself to a test campaign and send an email with links etc... if they work.. you should be good.

Also... I just have a normal VPS from contabo with ubuntu 18 ... I didn't do anything weird with it so I don't know why this happened.
 
Top