[Fix Release] - Mailwizz 1.3.6.5

Status
Not open for further replies.

Scott

Member
I am not sure if this is the best thing to do. It can be adjusted like so but i don't think it's fine, the idea is to send out the emails... Ifthere are arguments to change it, i will.
I understand, but for me it's best because I'm operating 3 separate lists within 1 customer account. And the delivery servers are different smtps so it would cause issues to have a campaign for list 1 be sent using the delivery server for list 3. My delivery servers utilize tracking domains.

So there's currently no way for me to achieve this without having 6 different customer accounts? (2 delivery servers per smtp, 1 for transactional mail to be sent immediately and 1 for bulk mail to be limited per hour as I'm trying to do).

And thanks for all of the help so far... I know I've been blowing up the forum all week but my system's finally operational minus limiting the sending for my bulk mail.
 
Last edited:

frm.mwz

Well-Known Member
I understand, but for me it's best because I'm operating 3 separate lists within 1 customer account. And the delivery servers are different smtps so it would cause issues to have a campaign for list 1 be sent using the delivery server for list 3. My delivery servers utilize tracking domains.

So there's currently no way for me to achieve this without having 6 different customer accounts? (2 delivery servers per smtp, 1 for transactional mail to be sent immediately and 1 for bulk mail to be limited per hour as I'm trying to do).

And thanks for all of the help so far... I know I've been blowing up the forum all week but my system's finally operational minus limiting the sending for my bulk mail.
no worries,
it is good for us to work through these questions,
as they bring about new aspects as well as ideas what to improve and clarify (for kb, for ui, etc)
 

twisted1919

Administrator
Staff member
@Scott - Actually you might be onto something. Looking in the code and running some tests, it seems that having set delivery servers for a campaign and the customer is not in a group, then emails are not sent with another delivery server, they wait till the selected server(s) is(are) available for sending.
If the customer is in a customer group, then the opposite it happens, if no campaign delivery server is available, the app selects one from the system to continue sending.
Above 2 cases cause an inconsistency, therefore i think it's best the app acts the same for customers in groups as for customers that are not part of groups, that is, if a delivery server is assigned to a campaign, regardless of the fact the customer is in a group or not, if the delivery server is not available for sending, then sending will wait till it is.

I made the changes accordingly and i have attached the DeliveryServer.php file that you can put in apps/common/models to override existing one. Give it a try and let me know how this goes. (please backup your existing DeliveryServer.php file)
 

Attachments

Scott

Member
@Scott - Actually you might be onto something. Looking in the code and running some tests, it seems that having set delivery servers for a campaign and the customer is not in a group, then emails are not sent with another delivery server, they wait till the selected server(s) is(are) available for sending.
If the customer is in a customer group, then the opposite it happens, if no campaign delivery server is available, the app selects one from the system to continue sending.
Above 2 cases cause an inconsistency, therefore i think it's best the app acts the same for customers in groups as for customers that are not part of groups, that is, if a delivery server is assigned to a campaign, regardless of the fact the customer is in a group or not, if the delivery server is not available for sending, then sending will wait till it is.

I made the changes accordingly and i have attached the DeliveryServer.php file that you can put in apps/common/models to override existing one. Give it a try and let me know how this goes. (please backup your existing DeliveryServer.php file)
@twisted1919 Thanks, will test this today.
 

Jason Thompson

New Member
Hi, i upgraded to version 1.3.6.5 yesterday and noticed that when i schedule or send a campaign it doesn't send, it just shows pending. Also same goes for follow ups.

Any idea what may be wrong, or have i missed something while updating it?
 

frm.mwz

Well-Known Member
@Scott - Actually you might be onto something. Looking in the code and running some tests, it seems that having set delivery servers for a campaign and the customer is not in a group, then emails are not sent with another delivery server, they wait till the selected server(s) is(are) available for sending.
If the customer is in a customer group, then the opposite it happens, if no campaign delivery server is available, the app selects one from the system to continue sending.
Above 2 cases cause an inconsistency, therefore i think it's best the app acts the same for customers in groups as for customers that are not part of groups, that is, if a delivery server is assigned to a campaign, regardless of the fact the customer is in a group or not, if the delivery server is not available for sending, then sending will wait till it is.

I made the changes accordingly and i have attached the DeliveryServer.php file that you can put in apps/common/models to override existing one. Give it a try and let me know how this goes. (please backup your existing DeliveryServer.php file)
this may have been one of the reasons why the settings in the 'sending' tab of customer (group) have not always had the effect wished for (and no matter how much re-reading of the explanations above the boxes, it could not have worked)

this is a good example that some systematic testing would be useful...

thx for sorting that out!

:)
 
Last edited:

Scott

Member
Seems to be working so far. Followup emails are being sent immediately and my bulk mail is being limited according to the hourly limit.
 

Jason Thompson

New Member
@Jason Thompson - Cleanup the application logs from backend > misc > app logs and give it some time to gather new ones and see if you spot there the reason.
Follow ups work ok, broadcasts are not being sent. I even reinstalled it on a different sub folder and used the same data base. I think something on this new update has triggered something
 

frm.mwz

Well-Known Member
Follow ups work ok, broadcasts are not being sent. I even reinstalled it on a different sub folder and used the same data base. I think something on this new update has triggered something
can you post your
sending tab
customer (group) settings
?
 

Napoolion

Member
Thanks for another release!

With the new version was also added "Toggle filters form". One of my customers can't click it, nothing happens. It works fine on my browsers. Maybe is there a way I can just display it default without hiding it.




Or maybe is it possible for me to add that filter at the status, like it was in the old version and still on the list pages:


Thank you! :)
 

Rocky Rocky

New Member
whats the difference between
[DIRECT_UNSUBSCRIBE_LINK] and [UNSUBSCRIBE_LINK] ??
what is the better ?
@wissem
[DIRECT_UNSUBSCRIBE_LINK] is a single step to unsubscribe, after subscriber click this link , done! unsubscribed successfully.
[UNSUBSCRIBE_LINK] is two steps to unsubscribe, subscriber need to confirm unsubscribe and request unsubscribe reason as optional.
I prefer [UNSUBSCRIBE_LINK] for personally in case click by mistake.
It may also depends on your "Opt out" options, single opt-out or double opt-out. I didn't test each options . sorry. just for your reference.
 
Last edited:

majid1f

Active Member
Hi i got this error when update:
Fatal error: Cannot override final method ExtensionInit::runQueriesFromSqlFile() in /mydomain.ir/public_html/apps/extensions/support-tickets/SupportTicketsExt.php on line 281
 
Last edited:

majid1f

Active Member
Thanks for new feature :)
Right now, How is it possible force customer use unsubscribe link or unsubscribe url (I mean required one of them)?
 

twisted1919

Administrator
Staff member
@frm.mwz - answering your questions now, sorry for the late reply on them:

#1 How is the next version coming along?
I will make it available today. We're at 1.3.6.9 internally already ;)

#2 Is the emails per connection setting already working across the app?
Yes, in the new version.

#3 Will there be the switch (off) for the html check, so that one can cut & paste own developments?
Not sure where this should be BUT the email parser has been improved drastically ;)

#4 Could you make it so that when one hovers over a customer's quota, the app will show a tooltip explaining exactly how the quota is determined by all relevant settings as well as sending speed?
I placed a link to the KB instead. The KB will contain all the right explanation.

#5 Can you make it have complete records for double opt-in, ie for the first and the second opt-in, both with date, IP, email, URL, etc?
It's a bit too late for this, will take a note for the future release though ;)

Thank you, good questions as always ;)
 
Status
Not open for further replies.
Top