Failed to create cache directory /tmp/ hash


Anyone had this issue before? None of my emails send. All say "Giveup" and then cite the reason to be "Failed to create cache directory /tmp/" followed by hash.

BTW, how can we delete the campaign delivery logs in the backend? I set Delivery servers logs removal days on 7 but the logs keep staying. I now have almost 2k pages. And, there's simply no select and delete button which would be really handy here.

Any suggestions?
@mailmole - Are you sure that error about the /tmp/ directory related to your server and not to the smtp server? I think the smtp server is the one saying this error and has nothing to do with your app.
Related to campaign delivery logs, go to backend > settings > cron and select Yes for "Delete delivery logs"
@twisted1919, we are using multiple smtps from different hosting services. Some of them were started months ago and others just last week. It's a very diversified pool. But all return the same error "Failed to create cache directory " and they started suddenly at the same time. Now, all our emails have the status of Giveup.
The error stops every time when I run "php -q apps/console/console.php clear-cache --verbose=1" on the mailwizz vps. I tried it yesterday but the issue came back just a couple of hours ago.

Do you have any clues what could be making it recur so often?
@mailmole - i dug the codebase for that error message, and the only occurrence i see is in the swiftmailer library:
Screenshot 2018-11-15 12.46.40.png
Now, if swiftmailer wants to write any cache, in does it in the /tmp directory of your server.
You said that the issue got better when you cleared the cached and then came back a while ago, which makes me thing the issue got resolved because you freed disk space when you deleted mailwizz's cache, and now when mailwizz started cache things again, the issue appeared because you have issues with the disk space, so can you check on that ?
You can put a cron to run every two hours and call the command you ran "php -q apps/console/console.php clear-cache" but again, that won't fix the underlaying issue, just postpone it.
@twisted1919, here ar ethe contents of the vps's tmp:

drwxrwxrwt 8 root root 4096 Nov 16 00:18 ./
drwxr-xr-x 23 root root 4096 Oct 31 08:46 ../
drwxrwxrwt 2 root root 4096 Oct 31 08:46 .font-unix/
drwxrwxrwt 2 root root 4096 Oct 31 08:46 .ICE-unix/
drwx------ 3 root root 4096 Nov 13 06:24 systemd-private-85b562a667824c4990e7ff4819d3b636-systemd-timesyncd.service-Q5Kfdy/
drwxrwxrwt 2 root root 4096 Oct 31 08:46 .Test-unix/
drwxrwxrwt 2 root root 4096 Oct 31 08:46 .X11-unix/
drwxrwxrwt 2 root root 4096 Oct 31 08:46 .XIM-unix/​

or did you mean tmp in var/www? The issue keeps recurring but I can't find anything in either tmp folders and my knowledge of swiftmailer is limited.

Also, I can no longer send anew campaign. It just gives me the error "The CSRF token could not be verified" when I click Save & Next to send a campaign.

It seems to be my VPS is running out of memory.
Last edited:
@twisted1919, my current build is:

4 vCore(s)
2.4 GHz
100 GB

But when I run df -h, I get the following breakdown:

Filesystem Size Used Avail Use% Mounted on
udev 13G 0 13G 0% /dev
tmpfs 2.5G 9.1M 2.5G 1% /run
/dev/sda1 105G 104G 412M 100% /
tmpfs 13G 0 13G 0% /dev/shm
tmpfs 5.3M 0 5.3M 0% /run/lock
tmpfs 13G 0 13G 0% /sys/fs/cgroup
tmpfs 2.5G 0 2.5G 0% /run/user/0

Sorry for the noob quetsion but where can I download the new version? Will I need to buy a new license? I just thought the initial license I bought was for the lifetime.
@twisted1919, thanks! Just noticed that the latest versions are available in the Downloads section. It would be useful if they mentioned the versions.

I am trying to install on a new server. Here's the stack:
Intel Xeon E3-1270v6
4c/8t - 3.8GHz /4.2GHz
32GB DDR4 ECC 2400 MHz
SoftRaid 2x2TB SATA
500 Mbps bandwidth
vRack: 100 Mbps​
No worries, and thanks! I did see that one in the screenshot. But, to download Mailwizz, I need to go to my profile and check Downloads where no version is mentioned. But, it was also a bit rushed on my side. So all good, I will keep it in mind in future :)
Any idea when the oldest one is dated ?
You can as well run the "daily" cronjob manually, this will again try to remove older logs.

They go back to June. Ideally, we'd like to know how to do it one go in bulk, especially at the point where they take up space.

BTW, in improt settings we can set the maximum size of a file allowed to import data. But, no matter what value we put, whether it's just 5MG or 100MB, the default stays at 2MB. For example, we set the max size to 5MB and tested an import. But, we got the following error:
  • Your form has a few errors, please fix them and try again!
  • The file "part-1_aa.csv" is too large. Its size cannot exceed 2097152 bytes.
This is in 1.6.5. I also noticed that in the older versions of mailwizz.

Why the max file size in the Import settings doesn't overwrite this default? Why does it work only when I change the max size in etc/php/7.1/apache2/php.ini which is outside of the var/www/mailwizz folder?

Also, another, even bigger issue, is that after I migrated to 1.6.5, I noticed that lists show incorrect counts. For example, when I go to Lists, it shows a count of 16k for a list that is actually 156k. Here's the screenshot:

But, when I go to check the list's subscribers, I see that 156k was found in the list. You can see it in the bottom right corner at

It seems like the list shows the count of the last batch imported, although its actual count is far greater than that.

Why does this happen? How can we fix it?
Last edited: