Zero Bounces in MW with AWS SES

nadworks

Active Member
This is an odd one and prob. down to my lack of understanding.
Since switching from Sparkpost to Amazon SES (web API), I do not see any bounces in MW. There were always the odd hard bounces, but not for the last 6 weeks, despite frequent sending.
I have not set up a bounce server as I gathered from previous posts here that it's not required for AWS (and it wasn't for Sparkpost either). I can see from my SES Reputation Dashboard that I have an overall bounce rate of 1.12%. So where are these addresses?
Or rather, how do I set up MW to pull these records into the blacklist?
 
Last edited:

ghimes

Member
Staff member Support Staff
When you setup your Amazon SES delivery server, Mailwizz will automatically create in Amazon SES, a SNS Topic that will subscribe to the following endpoint: http://YOUR_MW_APP/index.php/dswh/MW_DELIVERY_SERVER_ID. This endpoint is used to report the bounces to Mailwizz. Can you please check if this is set correctly in your Amazon SES account?

Cosmin
 

ghimes

Member
Staff member Support Staff
Why don't you try a test campaign to a fake email using this delivery server, to see what happened?
 

nadworks

Active Member
Ok, just sent a test to a fantasy email address.
When I try it with my personal email client, it bounces immediately, so I know it should also trigger a hard bounce with MW.
However, no bounce was registered. Nothing in the bounce log, and a "0" bounce in the campaign stats.
 

nadworks

Active Member
The dashboard only shows aggregated values, so hard to tell, but there have been a few bounces from previous campaigns of the last 6 weeks registered.

The test bounce I just sent is not visible yet. Unfortunately, there's no actual list of bounces, just those basic graphs.
 

nadworks

Active Member
Just wondered if there's a solution I could try. I have just sent a small campaign which again shows zero bounces in MW, but 14 in the SES dashboard. This campaign went to the same list as last week's and received the exact same number of bounces, telling me that none of them are being filtered out - not at the MW side and not at SES either. This is a pretty bad situation since it means I'm unable to exclude hard bounces at the moment.

What are my options? How can I troubleshoot this?


MW campaign:

Annotation 2019-12-09 230550.png

SES dashboard:
Annotation 2019-12-09 230450.png

And the SNS topic:

Annotation 2019-12-09 230226.png


 
Last edited:

nadworks

Active Member
Thanks. I did, but didn't think it was relevant, because bounces always worked until I switched from Sparkpost to SES.

Did you see the SNS screenshot I posted? According to the delivery server info popup, it uses the correct endpoint.

I'm assuming the fact that I'm getting...
Error 500!
SNS message type header not provided.
... when following my webhook endpoint URL, is normal behaviour?

Also, my crons (looking at the cron jobs and cron history) seem fine.

And last but not least, I'm not familiar with SSH and don't really have the option to command line into the server, unfortunately. I was hoping it was simply a matter of not having ticked a vital box or being able to troubleshoot the issue.
 
Last edited:

nadworks

Active Member
I've now set up a SendGrid API and SendinBlue API server in MW, and both successfully captured bounces the way it should. But I'd much prefer to continue using SES.

Does that possibly narrow down the problem? I'm not knowledgeable enough.
Can anyone help?
 

nadworks

Active Member
After several tests today, I asked my host to temporarily disable the firewall. And that did the trick - bounces were suddenly registering. So in order to create the required exception, I'd need to know which incoming port to open up to let the SNS topic send bounces.

@twisted1919, would you be able to help with this? Could it be the same port that you guys managed to open for this issue?
 

ghimes

Member
Staff member Support Staff
Hello,
From Amazon SES documentation:
You can use Amazon SNS to send notification messages to one or more HTTP or HTTPS endpoints. When you subscribe an endpoint to a topic, you can publish a notification to the topic and Amazon SNS sends an HTTP POST request delivering the contents of the notification to the subscribed endpoint. When you subscribe the endpoint, you choose whether Amazon SNS uses HTTP or HTTPS to send the POST request to the endpoint.
So the port to be opened is 80 for HTTP or 443 for HTTPS (these are the defaults). I suppose this is not the issue, but maybe you need to whitelist the incoming IP in your firewall rules.

Cosmin
 
Top