Amazon SNS bounces / complaints

eggerda

Member
Hello, I've finally gone live with a small percentage of our opt ins with MailWiz. We are using SES as our sending server, and emails are going out properly.

However, I notice we are not getting any bounces in MailWiz.

I have setup the S3 Access Key ID and Secret Access Key properly - which is how emails are being sent out.

I've also create a subscription to SNS with this URL:

https://myurl.com/index.php/dswh/2

However, I'm not getting any bounces being reported to MailWiz - and there have been bounces.

What could I be doing wrong? Any success with this for anyone?

Thank you!

Dan
 

eggerda

Member
I'm getting a strange error that MailWiz doesn't know the message type of the SNS message.

2019/09/27 15:31:50 [error] [exception.RuntimeException] [86.122.62.200] RuntimeException: SNS message type header not provided.

Do I need to "include original headers" in the SES notification config? Could that be why?
 

eggerda

Member
@twisted1919, ok updated you in PM.

Is anybody's SNS bounce/complaint processing working for them currently? All is setup properly in SES, bounces and complaints pointing to the SNS topic - which in turn points to the delivery server "listener" in MailWiz.

Bounces are not being read into MailWiz still...and I've even deleted the SES delivery server, and created a new one (using the API option SES delivery server type.)

Any guidance/confirmation that this process is currently working would be greatly appreciated!

Thank you...
 

eggerda

Member
It was cloudflare BLOCKING the requests! It works perfectly now that I've adjusted the firewall rules. I feel really bad about this - it was my mistake I missed this. @twisted1919 supported me the whole way, tested things, and helped me so much.... MailWizz is an awesome software, and @twisted1919 gives amazing support. Lucky to have what he has built. Thank you!
 

nadworks

Active Member
I have exactly the same problem. Sorry for double-posting (https://forum.mailwizz.com/threads/zero-bounces-in-mw-with-aws-ses.6429/#post-40733), but only just found this thread.

No bounces coming into MW, despite all SES settings being in place and sending working correctly. Bounces are being registered at AWS' side and SNS is in place as it should. Yet nothing's pushing through to MW.

I'm not using cloudflare or any firewall. If I have to make DNS changes, I'd need to know what and where.
Obviously I'd love a solution a.s.a.p.
 

nadworks

Active Member
@nadworks - this was on your side because of the firewall, right?
Yes, it was a matter of creating firewall exclusions for the AWS IP addresses.
But it would help to add this as a possible problem and/or additional setup action in some sort of troubleshooter. Mainly because I read about quite a few of these occurrences in the forum. But also because with service provider costs going up, more and more users will start switching to SES and increasing the user experience by providing solutions to likely issues is always a good idea.
 

nadworks

Active Member
Ok, this issue is now back big time for me and this time it's not the firewall. In fact we temporarily had the firewall completely disabled and still no bounces are being registered by MailWizz, despite there being some according to the SES side. Since I have not made any changes to my MailWizz installation, apart from updating the version, I'm at a complete loss to why this has suddenly stopped.
Here's what I tried:
  • removed and re-setup the delivery server
  • whitelisted all AWS IP addresses
  • temporarily disabled firewall on host server
  • checked all SES SNS topics are in place and are enabled
  • checked cron jobs and cron job history
None of these led to a solution. How can I check if the SNS topic is still correct. I know I'm clutching at straws, but that's all I have left.
It's currently set to
arn:aws:sns:us-east-1:12digitnumber:MWZSESHANDLER14 (the new topic after re-creating the delivery server)

- an odd coincidence is that these issues seemed to start with the first campaign after upgrading to the latest MW release. I know it only contained minor bug fixes. But could it have to do with the way I updated it this time or any other mistake I might have made during that process?

Another thought I had: I purchased a brand new MW license recently by way of saving some $$ to extend support. Since then I have accessed that newly purchased license for the recent update since it was higher up in my Code Canyon downloads. I know this is possibly daft, but could the fact that I didn't upgrade from my original 5-year old license purchase instance have created an issue for the application (i.e. a mismatch in license code somewhere in the unique settings)?

Any ideas hugely welcome.
 
Last edited:

nadworks

Active Member
I guess that has been fixed already.
Yes indeed. It looks stable again after working on this with the host all weekend. 99% certain it ended up being a combination of blocked IPs from the server-side, partially clueless host support and cache/delay in confirming a new SNS topic.
 
Top