Using correct character encoding to show latin characteres like 'ñ'

@twisted1919

When I edit some MW core file to do some translations not covered by MW translation extension I get some visualization errors when I try to translate the ´ñ' letter to spanish.

Example:

File: apps/customer/components/web/widgets/campaign-tracking/views/overview.php
Line: 20
Column: 84

When I changed: Campaigns for 'Campañas'

the Campaign overview page shows: 'Campañas

To solve this I used:

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

just after the line:

?>

and now the 'ñ' letter shows correctly.

Can you add some option into MW to indicate the correct Encoding for the whole system pages?

Or maybe I need to add the line:

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

to every customer/frontend page inside MW?

Regards

Carlos
 

twisted1919

Administrator
Staff member
@carlos alvarez - There's no such thing as content not being covered by the translation extension. Run it from command line and it will add all the missing strings in your files.

Can you add some option into MW to indicate the correct Encoding for the whole system pages?

Or maybe I need to add the line:

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

The correct encoding is utf-8. If you want your characters to save correctly, make sure your editor saves the files using the utf-8 charset ;)
 
@carlos alvarez - There's no such thing as content not being covered by the translation extension. Run it from command line and it will add all the missing strings in your files.



The correct encoding is utf-8. If you want your characters to save correctly, make sure your editor saves the files using the utf-8 charset ;)

I changed my editor to Notepad++ and all characters shows OK with UTF-8.

Thanks a lot !!!
 
Top