Sending time has 1 hour delay

panda

New Member
After migrate from VestaCP to Plesk Onyx campains are being send out with one hour delay. I checked Server time and local time are identical. Also in php.ini i have correct setting. I use +1 Berlin time zone. But Mailwizz seam to be stuck UTC. Mailwizz time shows correct but send out is with one hour delay.
 

panda

New Member
Local time and System time are showing identical time. The customers time zone is also identical. I have seen in Plesk you can also set time zone for cronjob which is also in same time zone as System time. I am using the backup system in mailwizz. And interessting is that backup and is perfomed at midnight but the email to inform me that it run successfully just get send out at 1am. So in mailbox the mail says sent at 1am. and in email content it says the backup was performed at 0 midnight. So wiered. I really do not get it.i am using Plesk onyx 17.0.17 running on an centos.
 

twisted1919

Administrator
Staff member
Maybe this helps, mailwizz forces all the timezone to be utc, for PHP but also for mysql, then depeding on the customer/user timezone, we add/remove offset to the current time.
The cron jobs usually run on UTC timezone thus your backup at midnight might be off and it runs at one hour and your email tells another hour (because it is formatted to match your timezone).
Anyway, there's nothing to worry about, it's just time conversion stuff, but everything happens utc.
 

panda

New Member
About the Backups i am not worried. But also the compains are being send out with the delay. UTC? mhhh the server is set on GMT(+1). But i played arround already switching the time zones but it had no effect.
 

frm.mwz

Well-Known Member
local time = user time = backend interface time if this user is logged-in
local time = customer time = customer interface time if this customer is logged-in
system time = server time
 

panda

New Member
so annoying. the shit just do not work. when compain is sending it says scheduled 2pm. in last activity window it says scheduled for sending at 1pm. for the same compain. My server is located in same local time. and it shows it also correctly like that at backend interface.
 

frm.mwz

Well-Known Member
so annoying. the shit just do not work. when compain is sending it says scheduled 2pm. in last activity window it says scheduled for sending at 1pm. for the same compain. My server is located in same local time. and it shows it also correctly like that at backend interface.

Can you get the results for the following commands (type these on the cli)
date
hwclock
?

Also, can you check the mwz time zone for
user
customer
?
 

panda

New Member
date is in CET time zone

hwclock says:

hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the --debug option to see the details of our search for an access method.


user and customer is in Europe/Berlin timezone
 

frm.mwz

Well-Known Member
Assuming by the above (not data there), that all these are the same time(zone): date, hwlock, mwz user, mwz customer, then try to set also the cron tz and the control panel tz to the same (I've seen even different versions of panels hande tz differently, what a mess).
If that does not work, try to set them all to UTC/GMT for a while, to see if that works. Once it does, set the customer into the tz you need.
 
Top