Saving HTML template doesn't work on it


I get this error, works fine on saving the first time on creating. Please fix.

Server error


The website encountered an error while retrieving It may be down for maintenance or configured incorrectly.
This is the error I get when editing any kind of HTML email and saving. What to do ?

Fatal error
: Maximum execution time of 30 seconds exceeded in /var/www/mailwizz/latest/apps/common/vendors/Codeigniter/system/core/Security.php on line 669

// replace illegal attribute strings that are inside an html tag
if (count($attribs) > 0)
$batches = array_chunk($attribs, 300);
foreach ($batches as $attribs) {
$str = preg_replace('/(<?)(\/?[^><]+?)([^A-Za-z<>\-])(.*?)('.implode('|', $attribs).')(.*?)([\s><]?)([><]*)/i', '$1$2 $4$6$7$8', $str, -1, $count); <<<<669
I am also facing the same issue, on root Ive installed wordpress and it generate 404 error if I save HTML template, if I dont change or upload any template and save it proceed to next screen. dont know what going on, what is wrong is there any thing wrong, using latest v1.3.6.0
You don't have permission to access /mailwizz/customer/index.php/campaigns/tn416m2pf8a75/template on this server.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Please advice
@Gore - Some templates are very complex and parsing them takes longer.
@nasirahmad - Most likely you have mod_security enabled on your host and it doesn't like the html you post. Look into into that and disable mod security if needed be.
I roll backed to previous version and using php5.5 so it some how resolved it..but i think u did smting on server so it is stoped again now..
I'm getting "Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/html/apps/common/vendors/Codeigniter/system/core/Security.php on line 669" error after enable debug.
And @Gore gives a solution "Increasing timeout to 60 fixed this."

But don't where i need to change to fix this error ?
Please suggest.