Enable debugging

twisted1919

Administrator
Staff member
As much as i struggle to make MailWizz EMA compatible out-of-the-box with any host, this is just unrealistic since the configuration vary so much between the hosts.
By default, MailWizz EMA runs in production mode, that is, no errors are show to the end user. That also means that if you get a serious error (most of the time a file permission error) the application will stop running and you will get a white screen.
If this happens, most probably you will open a support ticket but in order for me to be able to help you, you will have to enable debugging so that i can see exactly the error.

In order to enable debugging, all you have to do, is to open the 'apps/init.php' file and at line 16, right before the following piece of code:
Code:
// if debug mode is forced then go with it
if (defined('MW_FORCE_DEBUG_MODE') && MW_FORCE_DEBUG_MODE) {
[..]
add the line define('MW_FORCE_DEBUG_MODE', true); so that the code becomes:

Code:
define('MW_FORCE_DEBUG_MODE', true);
// if debug mode is forced then go with it
if (defined('MW_FORCE_DEBUG_MODE') && MW_FORCE_DEBUG_MODE) {
[..]

After this change, save the file and reload your web page, you should see the reason why the application stop working.
Please don't forget to remove the added line once you are done debugging.


[UPDATE]
Since version 1.3.5.7, in the init.php file, you will find:
PHP:
// set the developer ip addresses, separated by a comma
defined('MW_DEVELOPERS_IPS') or define('MW_DEVELOPERS_IPS', '');

// decide if we're in read only mode, note that MW_DEVELOPERS_IPS still have full access
defined('MW_IS_APP_READ_ONLY') or define('MW_IS_APP_READ_ONLY', false);

// whether we should force debug mode
defined('MW_FORCE_DEBUG_MODE') or define('MW_FORCE_DEBUG_MODE', isset($_SERVER['REMOTE_ADDR']) && in_array($_SERVER['REMOTE_ADDR'], array_map('trim', explode(',', MW_DEVELOPERS_IPS))));

// if debug mode is forced then go with it
if (defined('MW_FORCE_DEBUG_MODE') && MW_FORCE_DEBUG_MODE) {
[...]
In order to force debug you'll have to define the debug mode as in:
PHP:
// set the developer ip addresses, separated by a comma
defined('MW_DEVELOPERS_IPS') or define('MW_DEVELOPERS_IPS', '');

// decide if we're in read only mode, note that MW_DEVELOPERS_IPS still have full access
defined('MW_IS_APP_READ_ONLY') or define('MW_IS_APP_READ_ONLY', false);

// ADDED THIS before the initial check for debug mode:
define('MW_FORCE_DEBUG_MODE', true); 

// whether we should force debug mode
defined('MW_FORCE_DEBUG_MODE') or define('MW_FORCE_DEBUG_MODE', isset($_SERVER['REMOTE_ADDR']) && in_array($_SERVER['REMOTE_ADDR'], array_map('trim', explode(',', MW_DEVELOPERS_IPS))));

// if debug mode is forced then go with it
if (defined('MW_FORCE_DEBUG_MODE') && MW_FORCE_DEBUG_MODE) {
[...]
 
Last edited:

icactive

New Member
hi thank you for prompt respond.
i have added the above lines.

now i get.
Fatal error: Namespace declaration statement has to be the very first statement in the script in /home/statusco/public_html/emarketing.co.id/app/apps/common/vendors/Composer/vendor/composer/ClassLoader.php on line 13

does it look good, so we can resolve the problem?
thanks
 

twisted1919

Administrator
Staff member
Can you zip the ClassLoader.php file from /home/statusco/public_html/emarketing.co.id/app/apps/common/vendors/Composer/vendor/composer/ClassLoader.php and attach it here?
Also, what PHP version are you on right now and what mailwizz version ?
 

icactive

New Member
hi on the attachment you'll find the class loader you've asked.
my server php version is Current PHP version: 5.3.29

and i've just redownload and updated the latest mailwizz version.

i have no idea whats the tutorial you've sent above. could you explain how?

many thanks
 

Attachments

icactive

New Member
hi, i have to go now. but really need to have this issue fixed .
here bellow is the cpanel details in case you need the access to the server to check the issue
[EDITED]
thank you
kind regards
 
Last edited by a moderator:

twisted1919

Administrator
Staff member
@icactive - This is a public forum and you've posted your login credentials to cpanel... go and change them now please and PM me the new ones.
 

twisted1919

Administrator
Staff member
I see no error at all, the page just renders, here's my ip in case you want to whitelist it: 31.6.14.163
 

Lester

New Member
@twisted1919
please help
They sent my campaigns stopped, can not send auto responders and not regular campaigns.
I updated to version 1.3.6.0 to
I have debugging enabled, you help me check what's wrong?

my url is:
http://emailsync.co/sistema/backend/index.php/guest/index
user: sinergia_group@live.com
pass:---

I also noticed that the subscription link is not activated.
should always copy and paste it into your browser, and that many people do not, please help.

thanks

Regards.

Lester
 
Last edited by a moderator:

Lester

New Member
Hello @twisted1919 , Thanks for your attention, you can see the picture: this is the cron. My installation is in: emailsync.co/sistema/ -Root folder is: home/adminsr -
I have that wrong? -.. thansk
 
Last edited:

twisted1919

Administrator
Staff member
That looks good.
Did the campaigns used to send emails and now out of a sudden they simply stopped?
Can you go to backend > settings > cron and in the "Campaigns at once" field put 50, save your changes and wait few minutes and see if your campaigns start sending?
 

Lester

New Member
I'm sorry @twisted1919
still does not work?

My autoresponder campaigns are not sent, nor the regular season, the subscription emails if they work. What you will be happening?
what else I have to do, please help.

thanks.
 

twisted1919

Administrator
Staff member
@Lester - Ok, so the regular campaigns send, but the autoresponders don't send, right?
How many autoresponders you have now? What are the settings from backend > settings > cron > campaigns at once?

Also, pleas ebe aware that AR will be sent only to people that have been added into the list after the AR has been created.
 
Top