Problems with Links


New Member
Thank you for the help getting the tracking domains configured. All are configured, independently tested, and routing to the IP address of the server, and showing the same content as the main domain on the server.

However, when I send out emails, I'm getting some odd results.

Here is my setup:

Elastic Email

Server Domain: - never want this visible.
Sending Domain:
Tracking Domain:

Here, I'm doing a campaign sending with Domain2 ...

In the email, the link to the website we want people to visit is being rendered as:

When I click the links in that email (using I get

Note that the DNS is working, it is reaching the right site, the name of the main server is showing in the blurred area.

SES Email

Server domain:
Sending Domain:
Tracking Domain:

Here, the links in the email work and are using the tracking domain properly.

Note that the hyperlink in the SES emails is very different than in the Elastic emails:
(this link is working perfectly)

I don't know why they are different - is that an Elastic vs SES thing?

The SES Problem ...

HOWEVER, the opt-out link uses the tracking domain (I didn't set it up that way, did not create anything custom, it is just doing it) but it is then doing a redirect to the main domain without the : in the address

In other words...

Is redirecting to:

Note 1: the redirect is to http://https// ...
Note 2: both http:// and https//, I think because the https// is missing the : and browser is interpreting it as one long URL

If I manually edit the URL right in the browser from:
to >>
^--- removed extra http:// and added the : after the https

Then it works PERFECTLY, so the "true" opt-out link would work, but the missing : in the https:// is causing the problem

Just to eliminate any issues, I went back to the tracking domain, and I've tried setting the tracking domain as https and then as http to see if either was causing the problem, but the same result.

Same result whether Chrome, Firefox or Edge

Any thoughts?

Thank you
In the email, the link to the website we want people to visit is being rendered as:
This is not a link generated by MailWizz. Maybe disable tracking at the EE side to avoid this problem.

but it is then doing a redirect to the main domain without the : in the address
Please see
OK if this helps anyone else ... the WYSIWIG link editor with the unsubscribe_url short code did not work whether I used http or https

If I selected protocol "other" from the dropdown, or if I manually added the code, then it worked.

It appears the shortcode embeds the protocol and then the WYSIWIG drops an additional protocol in front of it which was causing the errors


Lines 112 and 114 - created via the WYSIWIG and choosing a protocol - both fail

Line 116 - created via WYSIWIG and choosing protocol "other" - if you choose "other" it does not add any protocol

Line 118 - I manually added this as shown

116 and 118 worked perfectly, the versions on 112 and 114 caused the problems.

Hope this helps...
Just a follow-up, the issue with ElasticEmail and the tracking links

They are doing tracking on their end, so they are replacing the links with their own tracking links.

They let you do custom tracking domains, like:

However, I had pointing at Mailwizz

Instead, if they are doing the tracking, you need to set your DNS:
tracking CNAME (assuming you use their API)

That cleared it right up.