Our XML (RSS) Feeds stopped working in version 1.8.5 of Mailwizz


Has anyone else run into this problem? We have been sending a daily Newsletter to 100k subscribers for almost 2 years now. Except for a recent bug in MW, that was fixed in a previous version, the XML RSS Code has been working flawlessly.
On 09/26/19 I updated PHP on our server to version 7.3.9 as we were getting warnings to update PHP. I also updated MW to version 1.8.5. Now when we send the email template with the feeds, which has not changed, we only see the Titles of the RSS source but NOTHING from the Feed itself. Note that we pull RSS feeds from 8 different sources....so it's not like a particular feed was having temporary problems

Does anyone have any information as to why the code is no longer resolving properly? Do we have to set a switch in MW options somewhere to process the XML?

This is hurting our business greatly. Any help would be appreciated.
Hi. FYI I tried a couple different things to fix the problem but with no luck. First I downgraded PHP back to 7.0 to see if that helped. It didn't work.
Next I created a brand new small Template with just one XML RSS call to see if that would work. It did not.
Then I restored the 1.8.3 version of the PHP code to my HTML public folder. That did not work.
Finally I restored the backup SQL database from the 1.8.3 version. That did not work.

But here is some possibly important new info. At the time I updated MW and PHP, I also moved the disk image to a new Amazon SES server with more CPU power. We had been seeing 100% CPU usage during the campaigns on a server with 8 CPU cores and 60 GB of RAM. Yes I was surprised too, but the database has 3.4 million subscribers over 100 lists. However, our XML RSS feeds were still working fine.

So to fix CPU overage, I upgraded the server to CPU of 16 Cores and 64 GB of RAM.

Following the upgrade of MW to 1.8.5 , PHP to 7.3.9 and the more powerful server...the XML RSS Feeds failed to work.

So I am attaching a zip of the HTML newsletter we have been using that worked fine before all the upgrades.
Unfortunately I did not save a version of the older Amazon EC2 server. I have done 3 previous EC2 server upgrades with no problem whatsoever...so I was not expecting any problems this time. Lesson learned. Next time I will create a disk image of the old server, use that to build a faster server...but retain the old server as backup.

Whatever the reason we are stuck. Is there any way to trace the processing of the XML in the new server to see where it fails?


  • Clarion - Kitchen Sink - needs PIB.zip
    6.9 KB · Views: 9
Quick question, are you sure you're not blocking outgoing connections from your new server?
I tried the above template and it all works just fine.
We also released a new update today, maybe that fixes the issue, but first see the firewall, from the server try to curl or wget one of the feeds and see if you can get them.
The mail is going out just fine and it is being received by the recipients.
Its that the XML is not being processed.
I have attached a screenshot of a test so you can see what is being received by subscribers.
Would it be possible for me to do a clean install of MW 1.8.5 on another EC2 server and then restore the Database that was converted during the update from 1.8.3 so we don't lose our history??

The curl command is returning data. I have attached a screen shot of the console.EC2 Curl command returning data.JPG EC2 Server Inbound Firewall rules by Amazon.JPG EC2 Server Outbound Firewall rules by Amazon.JPG MW-XML-not-processed.JPG
@Papapooch - I see, that looks good actually.
Can you please upgrade to 1.8.6 which i released today and see if that fixes your issue? (test on a new campaign after upgrade)
If that doesn't, then we'll have to get some kind of access to see what is going on.