Images not showing up after uploading my html email template

ronball

Member
@twisted1919
Can you please help me fix this issue? I've been researching a lot these past few days and I cant find the solution on...
my html email template images not showing up and some issues as shown on the image below

The test email that I sent still does not show the images on it.

Can you also please check from your end my DKIM and DMARC error?

mailwizz issues 5.19.2020.png
 
Last edited:

ronball

Member
@twisted1919
I've read about hotlink protection but i have no idea how to enable/disable it on mailwizz
I've read about email parser software but is kinda lost on how to do it also
I played around Mailwizz settings/campaigns and "enabled" attachments, added png and jpg on allowed extensions as shown below but nothing seems to work.......my html email template still does not show the images that is supposed to be there.
Please help. Thank you
added allowed extensions png & jpg.png
 

twisted1919

Administrator
Staff member
Can you also please check from your end my DKIM and DMARC error?
Yeah, you have none. Are you sure you added the DNS records in the right place?

I've read about hotlink protection but i have no idea how to enable/disable it on mailwizz
That doesn't apply for you, your problem is strictly related to really bad DNS records for your domain which makes ESp see your emails as spam and because of that they don't load the images.

As i said, let's first fix all your dns records, then you'll see how this gets also solved.
But to fix the DNS records, you need to add them in the right place.
I see your domain name servers are:
Name Server: NS13.DOMAINCONTROL.COM
Name Server: NS14.DOMAINCONTROL.COM

Which means you're using godaddy for the dns records (which we know by now, right?), so that's where you have to add the records.
Can you also show us a screenshot with the dns records for your domain from godaddy so we can check them?
You can also reach godaddy support for help related to these things, this is not really an issue with mailwizz, but if we can help, we will.
 

ronball

Member
Please see my DNS settings and guide me on which to edit and how to edit the wrong settings i may have done. Thank you
DNS settings 5.20.2020.pngDNS settings2 5.20.2020.png
 

twisted1919

Administrator
Staff member
Okay, so let's take it one by one:
1. DMARC - I think in the name field you should only have _dmarc not _dmarc.geniusdeals.org, so correct that.
2. DKIM - key001._domainkey - This looks like a good record. Where did you get the instructions from, to add this record?
3. SPF - This looks correct.
 

ronball

Member
1. I'll edit my DMARC DNS records and hopefully gets the error corrected
2. I forgot where I got my DKIM, I just followed a youtube video tutorial on where to put the private & public keys
3. MX TOOLS is reporting my SPF is ok

If I upload my html email template, the images are not showing, meaning I have not yet sent it for trial sending...

by the way, if I upload an html email template where does it go? Does it go straight to godaddy server/s?
 

twisted1919

Administrator
Staff member
I forgot where I got my DKIM, I just followed a youtube video tutorial on where to put the private & public keys
yes but these need to match your smtp sending server, you can't just throw there some dns records and expect to work :D
What are you using to send your emails with, is it your own smtp server or a 3rd-party?

If I upload my html email template, the images are not showing, meaning I have not yet sent it for trial sending...
Send me the email template, let me check it ;)

by the way, if I upload an html email template where does it go?
In Mailwizz's file system, it's stored on your hosting account where mailwizz is hosted.
 

ronball

Member
yes but these need to match your smtp sending server, you can't just throw there some dns records and expect to work :D
What are you using to send your emails with, is it your own smtp server or a 3rd-party?

>>>>>>>i have attached herewith the delivery server Im using in sending the test emails. I'm planning to use sendgrid as my smtp but only after I have cleaned my email list. I will engage the services of debounce.io to clean my email lists

Send me the email template, let me check it ;)
>>>>>>>where do i send it?


In Mailwizz's file system, it's stored on your hosting account where mailwizz is hosted.
>>>>>>>ok noted, could it be that digitalocean (vps provider) is blocking the images?

delivery server.png
 

ronball

Member
@twisted1919
With the current SMTP set-up that i have, does it mean that digital ocean is my current email host and not godaddy? pardon me for these naive questions

I called up godaddy yesterday and they say that the issue of my missing images on my html email template is not attributable to them but should be resolved by Mailwizz since they are not the one (godaddy) who is hosting my email client....who's really hosting my email client? Is it digital ocean or godaddy? I'm getting confused

If I choose sendgrid as my default smtp service provider....should I get the DKIM from sendgrid? Is this the case why my DKIM is not configured properly?

Can I get your email where i can send the zipped filed of my html email template?

Please enlighten me on my confusion. Thank you
 

mariocesar

New Member
I had the same problem running with digital ocean, I have the same settings as you my domain is with godaddy a friend refer me to Cloudways and now app is running very good, you can chose digital ocean again or a different data center, but app is running trough Cloudways.
 

mariocesar

New Member
Yes, I had the same problem my domain is with godaddy and my DNS settings pointing to them, I believe something wrong at their end, since I change to Cloudways everything works smooth using Amazon SES also, of course you have to install app again but is very easy with them, I used Filezila to upload app, just set your permissions and that is it.
 

ronball

Member
Is it a problem with godaddy or problem with digital ocean? If you may, can you send me a sample of your html email campaign? I'll send you mine too but do not expect the images to be there :)
 

mariocesar

New Member
Trust me I have been in your situation so many times not only with mailwizz but with other projects and at the end I fixed all of them, be patience try different options and you will make it work, by the way I sent you a message, is from napcolor did you receive it?
 
Top