HTTP ERROR 500 after installation

Exwizmuser1

New Member
Hello guys,

For starters, my background is I'm a frontend/backend programmer and have been using Sendy for over an year now, so I have a solid experience.
Yesterday me and my team decided to switch to Mailwizz, so my experience regarding this particular app is basic at most.

The hosting for this project is a freshly aqcuired VPS ( 1 vCore(s), 2.4 GHz, 2 GB RAM, 10 GB SSD, Local RAID 10 ), running CentOS 6 + WHM.
The installation of the Mailwizz app went smoothly, the only requirements that were not met by default were the PHP extensions for mbstring, zip archive and phpinfo, which of course I solved by installing the extensions via WHM.
However after installation, when trying to access any of the backend, frontend or customer links, I would get a 500 error. Here are the links
http://toprichdeals.com/mapp/backend/
http://toprichdeals.com/mapp/frontend/
http://toprichdeals.com/mapp/customer/

I've repeated the installation process in a new folder http://toprichdeals.com/mapp2/ with the same results: flawless installation process, but 500 error afterwards.

Here's what I've tried for debugging:
- checked the database, as I thought that maybe the import was flawed, however the DB was populated with tables and it seemed fine.

- normally a 500 error means a fatal PHP error has occurred server-side, so naturally I activated display_error from WHM and from backend/index.php ( error_reporting(E_ALL); ini_set('display_errors', 1); ) The result after this was ... nothing, no error displayed, nothing changed, cPanel error logs also are empty, which was mind boggling
Here's a display of phpinfo http://toprichdeals.com/info.php

- gave 777 rights to the entire folder on the 2nd install (not a wise thing regarding security, but what the heck, I was trying anything at this point) but no change


So, any thoughts ?
 
Last edited:

twisted1919

Administrator
Staff member
@Juni - Most of the time the issue is that not all the files copied over FTP, like 99% of the cases.
My advice is to try to copy the files once again and make sure no file fails uploading.
You can also open a support ticket with your FTP access and also the url of the app so we can take a look and see what is going on.
 
Top