French (special) characters not saved in mail template

Recif

New Member
Hello,

When I save my email template, all caracters éêà etc are removed with the right letter. Example : I put "amélioration", I save my template, then I reload it and I have "amioration" instead... Any idea??
 

frm.mwz

Well-Known Member
Hello,

When I save my email template, all caracters éêà etc are removed with the right letter. Example : I put "amélioration", I save my template, then I reload it and I have "amioration" instead... Any idea??
does it say utf8 in your code?
do u have all necessary extensions on the server (run also mwz requirements checker)?
just tested it, and it saves the word as you supplied it and it sends it out correctly, see attached
(it probably is not a bug, but a matter of settings or server setup)
 

Attachments

Recif

New Member
Hello,

Yes, utf8 on the source page.
I ran checker, reult : Congratulations! Your server configuration satisfies all requirements by MailWizz EMA.

My php.ini have the charset on ISO, but this is necessary for my main domain.
 

Recif

New Member
I hadded these 2 lines in the .htaccess but it oesn't work :

AddDefaultCharset utf-8
php_value default_charset UTF-8
 

Recif

New Member
It works: I mean the special chars are kepts in my templates.
I can't because the main site of this domain is using iso chars
 

Recif

New Member
Yes, I changed the Default_charset = UTF-8 in the php.ini, then I go on my template page, put some chars like ééé, then save the template and then reload it: the chars ééé were still there, so it works!
If I put Default_charset = ISO-xxxx, then my chars ééé disapear afetr the template is saved...
 

frm.mwz

Well-Known Member
Yes, I changed the Default_charset = UTF-8 in the php.ini, then I go on my template page, put some chars like ééé, then save the template and then reload it: the chars ééé were still there, so it works!
If I put Default_charset = ISO-xxxx, then my chars ééé disapear afetr the template is saved...
so why not leave it with utf8 if it works?

you may have to find a real solution for the website
what is running there?
 

Recif

New Member
No.

Initialy, the Default_charset = ISO-8859-1
This is my setting to make the root domain works with correct chars displayed on page (old website)
The Mailwizz is a subdirectory of this site (/mailing).
In this configuration, the chars are not working inside templates.

So, I modified Default_charset = UTF-8 to test. Then yes, it works in that configuration : the templates are saving my special chars.
But I return back to Default_charset = ISO-8859-1 because my chars on the main site (not maiwizz) are all broken.
 

frm.mwz

Well-Known Member
The Mailwizz is a subdirectory of this site (/mailing).
that is the problem

always have each site, each program in their own directory, not nested (ie sub dir, or even sub dir of sub dir, etc)

then you can set the php.ini for each directory and have it your way

(you see, when you describe it properly, things become clear, and help is truly possible)
 

frm.mwz

Well-Known Member
Well... I have to setup a new domain just for Mailwizz??
(a separate) directory (for mwz) under public_html

not (a new) domain

use the server control panel to determine where a domain points to (which directory), and/or
use 'htaccess rewrite rules' to coordinate sites/directories/files
 

frm.mwz

Well-Known Member
It will not solve my problem as the php.ini file is for the whole domain under /public_html
that's not how it works

you can put an individual php.ini into each (sub)directory

but to avoid putting one into so many ((sub)dirs), you better have the proper structure

(this has all been tried and tested, many times)
 
Top