Force FROM doesn't use the correct From address

Niko

Active Member
Hello @twisted1919 ,

under Sending Server there's Force FROM with the options Always/Never/When no valid signing domain.

The "When no valid signing domain" option seems to be giving some problems, because when the user sends an email, the from address is always the one set in the delivery server, and not the one set for the user under Domains > Sending Domains.

Under Sending Domains the user domain has DKIM set, and the system says it's verified. Still, currently it seems the only way to make the system use this address as sender is to set Force From -> Never.

Is there a way to make it work with the "When no valid signing domain" option?
Thanks.
 

Niko

Active Member
@Niko : check sending domain is verified perfectly or not.
yes, DKIM and SPF are set, so the domain is "verified" in the platform, but the emails are still being sent from the wrong sender address: from address is always the one set in the delivery server, and not the one set for the user under Domains > Sending Domains.

Do you have any suggestions?
 

Niko

Active Member
Would have to test this (as we usually use from=bounce=replyto=returnpath), but it may depend on whether you use swift (which takes what you set) or phpmailer (which does not take all as you set it).
I use already swift but nothing so I think this is a bug of mwizz
 

frm.mwz

Well-Known Member
I use already swift but nothing so I think this is a bug of mwizz
have you tried all 'force' options to 'no'
in that case it usually takes what is specified in campaign settings

also, what delivery server are you using, maybe that third party is forcing it
 

Niko

Active Member
have you tried all 'force' options to 'no'
in that case it usually takes what is specified in campaign settings

also, what delivery server are you using, maybe that third party is forcing it
If i set Force FROM --> Never, everything works correctly.
Unfortunately I can't set on Never, because the server is shared on many accounts and only some of them have enabled DKIM and their sending domain.

The option Force From --> When no valid signing domain should be useful in these cases, but unfortunately doesn't work. It always sends with the From email set in the server, and not with the domain set for the client.

The server is SMTP connected to PMTA.
 

frm.mwz

Well-Known Member
If i set Force FROM --> Never, everything works correctly.
Unfortunately I can't set on Never, because the server is shared on many accounts and only some of them have enabled DKIM and their sending domain.

The option Force From --> When no valid signing domain should be useful in these cases, but unfortunately doesn't work. It always sends with the From email set in the server, and not with the domain set for the client.

The server is SMTP connected to PMTA.

you can copy the DS and have a different policy on it re 'force from' and then assign it that other customer group

also, check if there is a pmta directive somehow interferes
 
Top