first redis send

Jason

Member
okay,

so just started sending out my first redis send, speed it pretty cool. But at 1 hour and sending 36k records, the campaign has died and i can't get into mailwizz customer campaign area properly to check stats - it goes to a 500 error page.

list size was a million, so that may be why :S, but surely should be able to handle it?

thanks
 

Jason

Member
mailwizz says 12% of the email has sent, pmta says 2.5% has sent. And the inbound volume is disappearing
 

twisted1919

Administrator
Staff member
gotcha, i assume it's stock install, no apache/php/mysql tuning of any sort?
Login via ssh, install htop on your server and start a monitor, see what the bottleneck seems to be.
If it's mysql, use http://mysqltuner.com/ to adjust your database settings.
 

Jason

Member
ah cool thanks - that looks really awesome

will try and have a go at installing it later! Can in work in tandem with regular non-queue sends?

do i need to delete the parallel sending cron?

also do i need to configure each and every server (port/user/pswd) in the single config file?
 

twisted1919

Administrator
Staff member
You're using the parallel cron with redis?
I'd say you disable both and simply use only mdp.
 

Jason

Member
hey - just looking at htop trying to figure out what the bottleneck is, its not exactly clear. Can you suggest what indictors may say 'this process is a bottleneck' please?

thanks
 

Jason

Member
okay i am working on the Go setup - will post a new thread on the question i have on it.

at the moment trying to get redis back at least to get some volume out. Only problem i have is i flooded the inno db table, running the
perl mysqltuner.pl you gave me, i get this;

[!!] InnoDB buffer pool / data size: 128.0M/3.7G

so thinking i flooded it, how do i clear the inno db buffer? I tried to restart mysqld and altering the my.conf file for the size, and i killed mysqld, wouldn't restart and gave a db exception error. thought it would flush it.

I changed my 'my.conf' file back to mainly what it was and i managed to get MW back online. restarting mysqld okay. But the buffer isnt clear still

other recommendations i got was;

-------- Recommendations -----------------------------------------------------
General recommendations:
Run OPTIMIZE TABLE to defragment tables for better performance
Restrict Host for user@% to user@SpecificDNSorIp
MySQL started within last 24 hours - recommendations may be inaccurate
Enable the slow query log to troubleshoot bad queries
Reduce or eliminate unclosed connections and network issues
When making adjustments, make tmp_table_size/max_heap_table_size equal
Reduce your SELECT DISTINCT queries which have no LIMIT clause
Set thread_cache_size to 4 as a starting value
Variables to adjust:
query_cache_size (>= 8M)
tmp_table_size (> 16M)
max_heap_table_size (> 16M)
thread_cache_size (start at 4)
innodb_buffer_pool_size (>= 3G) if possible.


if you could help with clearing the innodb buffer to get this somewhat going until i set up the pickup Go language. I would be so grateful

thanks
 

twisted1919

Administrator
Staff member
This:
Code:
InnoDB buffer pool / data size: 128.0M/3.7G
Says that your innodb buffer pool size is 128MB when it actually should be 3.7G, so you have to adjust that setting.
In /etc/my.cnf file make sure innodb_buffer_pool_size is 3.7G then restart your mysql server.
Make sure you aslo adjust the other variables as suggested.

if you don't know how to edit the my.cnf file, google can help you.

let me know if anything unclear.
 

Jason

Member
i changed the size to 3700m;

#innodb_use_native_aio = 0
innodb_file_per_table
innodb_buffer_pool_size = 3700M
innodb_log_file_size = 256M

tried to restart mysqld and it failed;

Stopping mysqld: [ OK ]
MySQL Daemon failed to start.
Starting mysqld: [FAILED]



edit : managed to get it to 1500M

edit2 : moved old innodb log files and changed to 3700M in my.conf. tried to restart mysqld and it failed again

edit3 : okay i realised im limited by my linode at 4GB RAM
 
Last edited:

Jason

Member
with the above changes, and some slow flow rating, i cannot seem to get emails into PMTA via redis or normal SMTP (not using queue)

I have tried to delete the delivery logs;
Displaying 1-100 of 455768 results

but i cannot seem to, is this where the bottleneck is occuring?

In terms of redis i killed the previous pid's and re-ran the command to get it running again, before trying to get some low volume out
 

twisted1919

Administrator
Staff member
So, the database is up again, right?
For campaigns delivery logs, if you delete that, you will lose your campaign stats as well and if you are okay with that you can directly delete your campaigns. I'd say you should do it from command line, to avoid the timeouts.
Anyway, let me know how can i help you more exactly, 455768 is not that much of records to pose problems.
 

Jason

Member
yes the database is up again

i need to know where the sticking point is. Do you think i should just delete the campaign and start over again? Something somewhere is stuck and the only thing i can see is the delivery logs are not processed.

what are your thoughts?
 

twisted1919

Administrator
Staff member
Side-note: That processed column from delivery logs isn't about what you think it is, it that was your guidance, forget about it :)
If i were you, i'd simply delete all the existing campaigns from command line, remove redis all together, adjust the crons and start from scratch.
To delete from command line:
Code:
# connect from command line
mysql -u YOUR_MYSQL_USER -p 
# enter password;

# select mailwizz database"
use DATABASE_NAME;

# delete * from campaign table:
DELETE FROM `mw_campaign` WHERE 1;

# wait for the data to be deleted, can take long time

#quit mysql terminal:
quit
 

twisted1919

Administrator
Staff member
You might want to put your app in offline mode while you're doing this ;) (Backend -> settings -> common)
 

Jason

Member
okay, i'll give this a shot :(, still need to get redis back to get the outbound speed until i work out the pickup directory.
 
Top