We want to increase minimum PHP version to run MailWizz!

Discussion in 'General discussions' started by twisted1919, Mar 8, 2019.

?

Can we increase minimum PHP version requirement for running mailwizz?

  1. No, i am using PHP < 7.1 and have no plans to upgrade

    0 vote(s)
    0.0%
  2. Yes, i am using PHP >= 7.1 (or less but i can upgrade)

    11 vote(s)
    100.0%
  1. twisted1919

    twisted1919 Administrator Staff Member

    Joined:
    Dec 27, 2014
    Messages:
    9,942
    Likes Received:
    2,328
    Hello,

    Right now mailwizz requires PHP >= 5.2 in order to work, which for us is really a big mess because we basically must always make sure mailwizz works with PHP 5.2, 5.3, 5.4, 5.5, 5.6, 7.0, 7.1, 7.2 and 7.3 which most of the time means a maintenance nightmare, our code is full of conditionals to match these php versions because some libraries support some versions of PHP while others don't.

    I know PHP 7 adoption is pretty large so it should not be a problem, but i also know lots, and i mean, lots of hosting accounts still use old PHP versions which means lots of people will have to upgrade, this is why we're having this discussion. We need to get an idea about what php version you guys are currently using and if upgrade is easily possible.

    If we decide to switch to PHP >= 7.1, this means it will take a while for the code cleanup, but after this we will have all advantages that PHP 7 offers, that is speed most than anything else, but also safety and stability and the ability to use latest versions of all libraries, which again mean security and stability. It will also mean a faster development since we don't have to target so many PHP versions.

    We're thinking to add a warning in mailwizz dashboard starting with next release which will tell you if you're using an older version of PHP and tell you to upgrade.
    Then we would keep this warning showing up till maybe August/September(is it enough?) while we upgrade the entire code base. Then in September maybe release Mailwizz 2.0 or something which will only support php >= 7.1.
    We will keep supporting Mailwizz 1.x branch for a few months afterwards, maybe till the end of 2019 so people have enough time to upgrade and then that's it, we will focus only on new version of mailwizz.
    You of course can stick to using Mailwizz 1.x as long as you wish, it's just we will not provide any support/fixes/etc for it.

    Does this sound like a plan, any things i missed?
     

Share This Page