underscores or hyphen just before @ makes email invalid

smol

New Member
I have problem importing emails: I cannot import emails with underscore or hyphen preceding the @ sign. They are considered has invalids.
The problem is that they are not... :-(

Examples of "should be valid" emails:
  • lenya-@
  • _ann_@
  • anjelica.ved_@
  • mail.sm_@
  • ir_p_@
  • ol--@
  • ...etc...
Is there something I can do to force the import of these kinds of emails ?

Thank you for your help.
 

twisted1919

Administrator
Staff member
@smol - Actually emails that start with - and _ or end with them are not RFC compliant, and because of that, if you try to send to such emails using swiftmailer, the emails won't go out and will block all the delivery because of that. So we took the decision to simply don't allow such emails.
 

Yas King

New Member
@twisted1919 Can you at least show us how to turn off or enable adding users with - or _.
Because I don't use swifmailer and lot of my subscribers have non rfc compliant emails, and i need to upload them.
Thank you
 

twisted1919

Administrator
Staff member
@Yas King - For now you can open /apps/common/components/validators/CEmailValidator.php and make the "
protected function preValidateValue($email)" look like:
PHP:
protected function preValidateValue($email)
{
    return true;
}
 

frm.mwz

Well-Known Member
@Yas King - For now you can open /apps/common/components/validators/CEmailValidator.php and make the "
protected function preValidateValue($email)" look like:
PHP:
protected function preValidateValue($email)
{
    return true;
}
Perhaps if phpmailer is enabled/used, it could automatically switch to allow all? Just an idea ;)
 
Top