too many connections from your ip (rate controlled)

Eric535

Member
Some of my messages are getting deferred when using sendgrid. I have a list of about 3000 emails but they all have the same domain name. What measures should I take when I send to lists that have the same domain. I have other lists too the have the same domain. Does MW treat deferred emails as bounced? In MW it says soft bounce but when I go to my sendgrid account it says deferred.

Error:
"too many connections from your ip (rate controlled)"
 

frm.mwz

Well-Known Member
Some of my messages are getting deferred when using sendgrid. I have a list of about 3000 emails but they all have the same domain name. What measures should I take when I send to lists that have the same domain. I have other lists too the have the same domain. Does MW treat deferred emails as bounced? In MW it says soft bounce but when I go to my sendgrid account it says deferred.

Error:
"too many connections from your ip (rate controlled)"
Normally pro MTA users like SendGrid will have directives/policies that would throttle the final delivery.
Are you sure it is not you (as it is your IP that is mentioned) going over the injection speed limit they are imposing?
 

Eric535

Member
Normally pro MTA users like SendGrid will have directives/policies that would throttle the final delivery.
Are you sure it is not you (as it is your IP that is mentioned) going over the injection speed limit they are imposing?


Me? How? Dont quite understand your question. That error is coming from Sendgrid when on the activity page. See snap.
 

Attachments

  • Screen Shot 2017-02-03 at 12.00.48 PM.jpg
    Screen Shot 2017-02-03 at 12.00.48 PM.jpg
    213.5 KB · Views: 11

frm.mwz

Well-Known Member
Me? How? Dont quite understand your question. That error is coming from Sendgrid when on the activity page. See snap.
If you run more than pcntl 10 processes, that may be it, as sendgrid allows only max 10 concurrent smtp connections, and only 100 msgs per smtp connection (in mwz ds setup called max connection msgs).
 

Eric535

Member
I went to the delivery servers and selected my sendgrid account and hit update, but I cannot seem to find any mention of max connections. See snap.
 

Attachments

  • Screen Shot 2017-02-03 at 2.19.59 PM.jpg
    Screen Shot 2017-02-03 at 2.19.59 PM.jpg
    411.9 KB · Views: 10

frm.mwz

Well-Known Member
I went to the delivery servers and selected my sendgrid account and hit update, but I cannot seem to find any mention of max connections. See snap.
The other pic indicated it was an smtp connection. That is why my reply was focused on their smtp limits and how to apply them in mwz. Please look into the ds which is sendgrid smtp configured (not web api).
 

frm.mwz

Well-Known Member
So maybe the API handles all of the speed and the connections?
Please post a screen shot of the overview of all your DS (delivery servers) (black out the parts you don't want to share of course) as you find it here
/backend/delivery-servers/index
The http web api is not handling the speed control, that is due to mwz settings, your server/host/dc and ds features.
 

Eric535

Member
I just have two. Sendgrid and Mandrill I havent used in a while. See snap
 

Attachments

  • Screen Shot 2017-02-03 at 4.11.20 PM.jpg
    Screen Shot 2017-02-03 at 4.11.20 PM.jpg
    173.2 KB · Views: 14

frm.mwz

Well-Known Member
I just have two. Sendgrid and Mandrill I havent used in a while. See snap
Oh, that's odd, from the error pic above I would have definitely said it is smtp...but there is none! Mh, so then perhaps try to use no more than 10 pcntl processes, ie 'Subscriber batches in parallel', try that and see if it works without error. Then you could try to increase it, but as stated above sendgrid does not want more than 10 parallel connections (though it can handle 3000 http web api requests per second).
 

Eric535

Member
Oh, that's odd, from the error pic above I would have definitely said it is smtp...but there is none! Mh, so then perhaps try to use no more than 10 pcntl processes, ie 'Subscriber batches in parallel', try that and see if it works without error. Then you could try to increase it, but as stated above sendgrid does not want more than 10 parallel connections (though it can handle 3000 http web api requests per second).

how and where would I do this?
 

Eric535

Member
Do i have to se the first option to yes and being that its already at 5 wouldnt seting it to 10 make it worse? See snap
 

Attachments

  • Screen-Shot-2017-02-07-at-12.57.34-AM.jpg
    Screen-Shot-2017-02-07-at-12.57.34-AM.jpg
    14.7 KB · Views: 6

twisted1919

Administrator
Staff member
@Eric535 - In the dev version i have entered a setting to allow you to pause x microseconds ( A microsecond is one millionth of a second. ) after an email has been sent and you can do this for all delivery servers.
Meanwhile, the fact you are rate limited is a bit weird, but i think we can avoid this issue. Can you please also attach a screenshot with the delivery settings from backend > settings > cron.
Should look like:
Screenshot 2017-02-07 12.49.09.png
 

twisted1919

Administrator
Staff member
@Eric535 - the settings already seem to be very low, can you try with 50 subscribers at once, maybe that will slow things down considerably till next release when you will be able to use the new setting?
 
Top