STUCK AT 5% PROCESSING.

KeithEmail

New Member
Here is what the application log says. Everytime I try to start a new campaign, it gets stuck at 5%.


2016/02/23 23:12:32 [error] [system.db.CDbCommand] CDbCommand::execute() failed: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away. The SQL statement executed was: INSERT INTO `mw_delivery_server_usage_log` (`delivery_for`, `customer_countable`, `server_id`, `customer_id`, `date_added`) VALUES :)yp0, :yp1, :yp2, :yp3, NOW()).
2016/02/23 23:12:32 [error] [system.db.CDbCommand] CDbCommand::execute() failed: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away. The SQL statement executed was: UPDATE `mw_campaign` SET `status`=:status WHERE campaign_id = :cid.
2016/02/23 23:12:32 [error] [exception.CDbException] exception 'CDbException' with message 'CDbCommand failed to execute the SQL statement: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away' in /home/credite1/public_html/email/apps/common/framework/db/CDbCommand.php:358
Stack trace:
#0 /home/credite1/public_html/email/apps/common/framework/db/CDbCommand.php(1313): CDbCommand->execute(Array)
#1 /home/credite1/public_html/email/apps/common/models/Campaign.php(1107): CDbCommand->update('{{campaign}}', Array, 'campaign_id = :...', Array)
#2 /home/credite1/public_html/email/apps/console/commands/SendCampaignsCommand.php(669): Campaign->saveStatus()
#3 /home/credite1/public_html/email/apps/console/commands/SendCampaignsCommand.php(389): SendCampaignsCommand->sendCampaignStep3(Array)
#4 /home/credite1/public_html/email/apps/console/commands/SendCampaignsCommand.php(335): SendCampaignsCommand->sendCampaignStep2(Array)
#5 /home/credite1/public_html/email/apps/console/commands/SendCampaignsCommand.php(227): SendCampaignsCommand->sendCampaignStep1('8', 0)
#6 /home/credite1/public_html/email/apps/console/commands/SendCampaignsCommand.php(177): SendCampaignsCommand->sendCampaignStep0(Array)
#7 /home/credite1/public_html/email/apps/console/commands/SendCampaignsCommand.php(108): SendCampaignsCommand->process()
#8 [internal function]: SendCampaignsCommand->actionIndex()
#9 /home/credite1/public_html/email/apps/common/framework/console/CConsoleCommand.php(172): ReflectionMethod->invokeArgs(Object(SendCampaignsCommand), Array)
#10 /home/credite1/public_html/email/apps/common/framework/console/CConsoleCommandRunner.php(71): CConsoleCommand->run(Array)
#11 /home/credite1/public_html/email/apps/common/framework/console/CConsoleApplication.php(92): CConsoleCommandRunner->run(Array)
#12 /home/credite1/public_html/email/apps/common/framework/base/CApplication.php(185): CConsoleApplication->processRequest()
#13 /home/credite1/public_html/email/apps/init.php(219): CApplication->run()
#14 /home/credite1/public_html/email/apps/console/console.php(28): require_once('/home/credite1/...')
#15 {main}
---
 
Last edited by a moderator:

VVT

Active Member
Should be in your mysql conf - my.cnf. Example : /etc/mysql/my.cnf . And there under [mysqld] directive, check if "wait_timeout" variable is set to a lower value (that's in seconds). Default value is 28800. If you don't have this variable set there, that means MySQL is running with the default value and no need to change anything (because 28800 secs is 8Hours). Then something else can be the problem. If you change the value, then you should restart MySQL server daemon to take effect.

BTW, Calm down buddy :)
 

twisted1919

Administrator
Staff member
@KeithEmail - This is your mysql server way of telling you that you want too much from it, it simply can't keep up and it simply dies with that error.
Beside @VVT says, most likely in Backend > Settings > Cron you have set a high value for Subscribers at once and because of this you get the error, so try to lower that to 300 - 500 at most.

Also, i really have a low tolerance for people that aren't polite, so please don't be that guy.
Thanks.
 

Dan O'Shea

Member
"Also, i really have a low tolerance for people that aren't polite, so please don't be that guy."

Yup, and for us who have the Mailwhizz posts sent to their email every morning to keep up with issues, not good to wake up and see an email subject "*** STUCK AT 5% PROCESSING. *** IS THIS ******". [Letters replaced by *.] I could quote more, but I think the point is made.

The Subject doesn't help the board members whatsoever in searching for issues for their problem. These members posts HELP others!!
Low tolerance?, I'm surprised you didn't give him his money back and move on.

All of us that use this program, most of the issues we have are having to do with 'our' servers, 'our' settings, 'our' typing, etc., etc., etc. Meaning, most issues are on the User-end, not the Programmer's end. This is one of the most rock-solid programs and installs I've ever done and my issues were always with 'me' or the 'host' company I use.
 
Top