Strange Wrong encode after campaign sent

nemesis82

Member
Hy all,
i have a strange issue with my html code only after the campaign was sent.
If i do a test email it work and work also if i do a web version check directly from mailwizz panel but when i send my campaign all link are changed with wrong code, see below an example :

Right link
Code:
http://mylink1/aff_c?offer_id=123&aff_id=1234&file_id=5678&url=http%3A%2F%2Fmylink2%2Faff_c%3Foffer_id%3D123%26aff_id%3D1234%26file_id%3D5678

Wrong link
Code:
http://mylink1/aff_c?offer_id=123&aff_id=1234&file_id=5678&url=http%3A%2F%2Fmylink2%2Faff_c?offer_id=123&aff_id=1234&file_id=5678

As you can see only a single part of the url come with char changed, other part take the right encode.
You could match first offer_id%3D123%26 with the second one offer_id=123&

I've solved adding %25 before each % but is possible enabling a check on test email or web preview ?
 
Last edited:

nemesis82

Member
@laurentiu no, i cannot. i get the html code from 1 of my customer, i could give only some info but not the html or the real link.
But the problem due to encode / decode of special character in <href url , you can try in your lab to create an url with special character as "file_id%3D5678" ( you must use % char ) and test with
- send test email ( it work )
- web preview ( it work )
- send campaign ( not work )
Maybe due to tracking link and redirect in browser during send campaign and in test email the track link is not applied.
 

twisted1919

Administrator
Staff member
@nemesis82 - the sequence %3D is actually the equal sign which is urlencoded while %26 is the % sign.
So they basically are the same thing.
MailWizz does some work on the urls when doing tracking, but regardless of that, the urls will continue to work even if mailwizz will decode/encode some of the params, so there's nothing to worry about as long as the click is tracked and leads to the right destination.
 

nemesis82

Member
@twisted1919 thanks for explanation but with track link the user's browser do a wrong urlencode . This is not an error of Mailwizz .
Is possibile apply the tracking link during the "send test email" feature ? Maybe there is a setting to enable this option that i don't known ?
In this way, we could see the real behavior and issue during redirect otherwise the test email is not the same as send campaign.
 

twisted1919

Administrator
Staff member
Is possibile apply the tracking link during the "send test email" feature ?
Currently no, because the tracking links are saved into the database.
Maybe the solution is to send a test campaign to a seed list, and then when all okay, send the real campaign. This is what we're doing.
 
Top