Strange issue - my user not receive campaign

Discussion in 'Common issues' started by nemesis82, Oct 8, 2018.

  1. nemesis82

    nemesis82 New Member

    Joined:
    Sep 19, 2018
    Messages:
    23
    Likes Received:
    1
    S.E:
    2019-09-17 13:35:43
    L.T:
    Regular
    L.C:
    1
    Hi,
    i have a strange issue.
    I have a lot of user in some Lists but If I see "campaign history" I don't see all campaign sent to the user.
    Example :
    List "A" with user "nemesis"
    List A : 1 campaign every day
    User history : I see the campaign until 3 day ago and stop.
    The same lists was sent today at all users but I not see the history. One last thing, the user didn't received the email ( also check on mta logs ) .
     
  2. laurentiu

    laurentiu Member Staff Member

    Joined:
    Mar 13, 2018
    Messages:
    117
    Likes Received:
    18
  3. nemesis82

    nemesis82 New Member

    Joined:
    Sep 19, 2018
    Messages:
    23
    Likes Received:
    1
    S.E:
    2019-09-17 13:35:43
    L.T:
    Regular
    L.C:
    1
    I have find the issue, this is the log of a campaign


    [2018-10-10 05:46:23] - Done processing 150 subscribers![2018-10-10 05:46:23] - Done processing the campaign.[2018-10-10 05:46:26] - This cycle completed in 25.07 seconds and used 2 MB of memory![2018-10-10 05:46:26] - CPU usage in last minute: 1.44, in last 5 minutes: 2.28, in last 15 minutes: 2.33![2018-10-10 05:47:01] - Starting the work for this batch...[2018-10-10 05:47:01] - Loading 5 campaigns, starting with offset 0...[2018-10-10 05:47:01] - Found 1 campaigns and now starting processing them...[2018-10-10 05:47:01] - Since PCNTL is active, we will send 5 campaigns in parallel and for each campaign, 30 batches of subscribers in parallel.[2018-10-10 05:47:01] - Temporary changing the campaign status into PROCESSING![2018-10-10 05:47:02] - Restoring the campaign status to SENDING![2018-10-10 05:47:02] - Campaign has been marked as sent because of MaxSendCount settings![2018-10-10 05:47:02] - This cycle completed in 0.09 seconds and used 2 MB of memory![2018-10-10 05:47:02] - CPU usage in last minute: 0.80, in last 5 minutes: 2.03, in last 15 minutes: 2.24!

    I don't understand 2 thing :
    1) Not always give me this error cause some campaign exit full of user ( all campaign are over 200K of users )
    2) I didn't set any limit.

    Any help is appreciated.
    Thanks
     
  4. nemesis82

    nemesis82 New Member

    Joined:
    Sep 19, 2018
    Messages:
    23
    Likes Received:
    1
    S.E:
    2019-09-17 13:35:43
    L.T:
    Regular
    L.C:
    1
    @adding issue :
    Other campaign log:
    Subscribers : 159.827
    Sent to : 100.619
    Campaign log :
    [2018-10-10 06:10:01] - This subscribers worker(#11) will process 119 subscribers for this campaign...

    [2018-10-10 06:10:01] - Running subscribers cleanup...

    [2018-10-10 06:10:01] - Checking subscribers count after cleanup: 119

    [2018-10-10 06:10:01] - Looking for subscribers for campaign with uid kh5863zsk4634...(This is subscribers worker #15)

    [2018-10-10 06:10:01] - Checking if the server is over quota...

    [2018-10-10 06:10:01] - Preparing the entire email...

    [2018-10-10 06:10:01] - Checking if pippo@example.com is listed in a campaign suppression list...

    [2018-10-10 06:10:01] - Using delivery server: 10.132.0.7 (ID: 19).

    [2018-10-10 06:10:01] - Sorting the subscribers...

    [2018-10-10 06:10:01] - Sorting the subscribers...

    [2018-10-10 06:10:01] - Entering the foreach processing loop for all 119 subscribers...

    [2018-10-10 06:10:01] - Checking if the server is over quota...

    [2018-10-10 06:10:01] - Preparing the entire email...

    [2018-10-10 06:10:01] - This subscribers worker(#15) will process 0 subscribers for this campaign...

    [2018-10-10 06:10:01] - Running subscribers cleanup...

    [2018-10-10 06:10:01] - Checking subscribers count after cleanup: 0

    [2018-10-10 06:10:01] - Sorting the subscribers...

    [2018-10-10 06:10:01] - Entering the foreach processing loop for all 0 subscribers...


    [2018-10-10 06:10:01] - Done processing 0 subscribers!

    [2018-10-10 06:10:01] - Done processing the campaign.

    [2018-10-10 06:10:01] - Entering the foreach processing loop for all 150 subscribers...

    [2018-10-10 06:10:01] - This subscribers worker(#13) will process 0 subscribers for this campaign...

    [2018-10-10 06:10:01] - Running subscribers cleanup...

    [2018-10-10 06:10:01] - Checking subscribers count after cleanup: 0

    [2018-10-10 06:10:01] - Sorting the subscribers...

    [2018-10-10 06:10:01] - Entering the foreach processing loop for all 0 subscribers...

    Campaign progress with the same log until finished wit no error

    [2018-10-10 06:11:02] - Done processing 0 subscribers!

    [2018-10-10 06:11:02] - Done processing the campaign.

    [2018-10-10 06:11:02] - Looking for subscribers for campaign with uid kh5863zsk4634...(This is subscribers worker #28)

    [2018-10-10 06:11:02] - Sorting the subscribers...

    [2018-10-10 06:11:02] - Entering the foreach processing loop for all 0 subscribers...


    [2018-10-10 06:11:02] - Done processing 0 subscribers!

    [2018-10-10 06:11:02] - Done processing the campaign.

    [2018-10-10 06:11:02] - This subscribers worker(#28) will process 0 subscribers for this campaign...

    [2018-10-10 06:11:02] - Running subscribers cleanup...

    [2018-10-10 06:11:02] - Checking subscribers count after cleanup: 0

    [2018-10-10 06:11:02] - Sorting the subscribers...

    [2018-10-10 06:11:02] - Entering the foreach processing loop for all 0 subscribers...


    [2018-10-10 06:11:02] - Done processing 0 subscribers!

    [2018-10-10 06:11:02] - Done processing the campaign.

    [2018-10-10 06:11:05] - This cycle completed in 4.07 seconds and used 2 MB of memory!

    [2018-10-10 06:11:05] - CPU usage in last minute: 1.69, in last 5 minutes: 1.93, in last 15 minutes: 1.84!
     
  5. laurentiu

    laurentiu Member Staff Member

    Joined:
    Mar 13, 2018
    Messages:
    117
    Likes Received:
    18
    This means you have changed max. subscribers value form: Campaign setup -> Max. subscribers and your campaign is send only to this number of subscribers.

    What value you have here?
     

    Attached Files:

  6. nemesis82

    nemesis82 New Member

    Joined:
    Sep 19, 2018
    Messages:
    23
    Likes Received:
    1
    S.E:
    2019-09-17 13:35:43
    L.T:
    Regular
    L.C:
    1
    Problem solved.... was a human issue ( sometimes I forget my human team ).
    Our operator ( don't ask why ) has set a limit of subscribers in all campaign..... thank you very much for your time
     
  7. twisted1919

    twisted1919 Administrator Staff Member

    Joined:
    Dec 27, 2014
    Messages:
    9,463
    Likes Received:
    2,223
    It happens :D
     
  8. Mbaeri Anselam Chukwuma

    Mbaeri Anselam Chukwuma New Member

    Joined:
    Sunday
    Messages:
    2
    Likes Received:
    0
    S.E:
    2019-04-03 00:13:06
    L.T:
    Regular
    L.C:
    2

Share This Page