Special characters not saved properly

Luis Aguilar

New Member
When I enter any text, for example the name of a list or a campaign , with special charcters such as ñ á é í ó ú the text is not saved properly.

For example:
List name: Boletin de noticias en español ==> It is saved as [URL='http://filateliaaguilar.com/mailwizz/customer/index.php/lists/np3087b09r4ae/overview']'Boletin de noticias en espa'[/URL]
Campaign name: Prueba de campaña => It is saved as '[URL='http://filateliaaguilar.com/mailwizz/customer/index.php/campaigns/rq6136d15ef8b/overview']Prueba de campa'[/URL]
Campaign content: ¡País España! => bol! Espa (<!DOCTYPE html><html><head><title></title> <meta name="charset" content="utf-8"></head><body>bol! Espa</body></html>)

I have tried this with two different browsers. I know that the database has all tables and fields with utf-8, but I don't know how to solve this and I need to be able to send emails with special charcters (Spanish characters)
 

Luis Aguilar

New Member
In the 'Campaign' template page, when I click on 'Save template changes', the page is reloaded with all the special characters removed. Correct me if I'm wrong but I think that nothing has been saved into the database yet, so it looks like it is not a problem related to the database coding.

What can I do to troubleshoot the issue?
 

twisted1919

Administrator
Staff member
In the 'Campaign' template page, when I click on 'Save template changes', the page is reloaded with all the special characters removed
Save template changes does save to database.

Do you have any filter enabled on your server, such as mod security or the like?
I am not sure how to have you troubleshoot this as there's no issue with the app but rather it's something local.
Do you have any extension in your browser that could cause this? Maybe disable them all and see ?
 
Top