Slow sending with ElasticEmail. Any way to increase speed?


New Member
Hi @twisted1919 ,

I sent a campaign using ElastiEmail and it took 14 hours to send to a 50k list.

I created a test list with 8 subs and tested sending using the Verbose command:

Here are the results:

[2015-10-26 09:45:22] Current progress: 8 out of 8
[2015-10-26 09:45:22] Checking if the delivery server is allowed to send to the subscriber email address domain...OK, took 0 seconds.
[2015-10-26 09:45:22] Checking the subscriber email address into the blacklist...OK, took 0 seconds.
[2015-10-26 09:45:22] Checking server sending quota...OK, took 0 seconds.
[2015-10-26 09:45:22] Checking customer sending quota...OK, took 0 seconds.
[2015-10-26 09:45:22] Preparing email...done, took 0.002 seconds.
[2015-10-26 09:45:22] -> Sending the email for by using direct method...done, took 0.324 seconds.
[2015-10-26 09:45:22] The email has been sent successfully!
[2015-10-26 09:45:22] Logging delivery...done, took 0.058 seconds.

[2015-10-26 09:45:22] Exiting from the foreach loop, took 2.905 seconds to send for all 8 subscribers from which 2.647 seconds only to communicate with remote ends.
[2015-10-26 09:45:23] Finished processing the campaign, took 3.102 seconds!
[2015-10-26 09:45:23] Finished the send-campaigns command!

The Backend -- Cron Settings are set to the following:

Subs at once: 500
Pause: 1
Send at once: 0 (disabled)
Emails per minute: 0 (disabled)
Change server at: 0 (disabled)

What can I do to increase sending speed? I need to send at least 15k/hour.

Last edited:
@twisted1919 The thread above refers to parallel sending when sending more than one campaign. Will this help if I only send one campaign at a time? All my subscribers are added to a single list.
It appears so, but scroll further down to be sure.

You should see a:

Why don't you use the "power you possess under your feet"? Setup a relay to ElasticEmail through your local email server. Connect MW to the local email server and send through that. You'll gain the advantage of pipelining and multiple connections to the receiving SMTP provider.


-s [number of connections]
-l [message size in bytes]
-f [From:]
-t [To:]

That is without any tuning on the sending and receiving ends.

First email came in at 07:47:29PDT to the receiving Postfix instance. The last email came in at 07:50:19PDT.


Be sure to contact ElasticEmail first to see what the connection and message per connection limits are.
@twisted1919 & @Mxyzptlk FishStix

I just checked and I don't have any other reference about PCNTL except the one here:

It doesn't say "PCNTL - enabled" anywhere.

I'm confused :). What should I do now?

@twisted1919 - Will the new sending method help if I only send one campaign at a time? Should I try what @Mxyzptlk FishStix suggested?

I have little experience with this stuff, it even took me an hour to figure out how to connect via SSH using Putty :)).

Any help would be greatly appreciated.