Server Error on Port 465, 587 - Possible Solution

Hey everyone. So most of you or some of you might be getting this error when verifying the server after you have added it. I dont have the error image at the moment, but i got the solution for it.

If you have to send e-mails using SSL or TLS by using port 587 or 465, you need to add an SSL Certificate on your domain name. It is recommended that you add a Wildcard SSL because e-mail servers like and MAIL. are considered as sub-domains.

And Wildcard SSL is added onto the main domain and sub-domains. This means, if you are using SMTP or MAIL. servers, you will be good to go with 587 or 465. TLS/SSL.

Only adding the Wildcard SSL may not resolve your issue. You may need to add these ports in your hosting if you are using a VPS or Dedicated server and have access to WHM.

I will attach the images for WHM.

Go into WHM>Service Configuration>Service Manager (Scroll Down and you will see something similar as shown in the image)

Just Enable Exim Mail Server (on another port) and add the ports.

Once done, save the settings and do a server restart.


If you don't have any SSL/TLS. Just enter in port 587 and for Protocol Select NONE. You should be done with the verification of the server.


  • Screen Shot 2017-08-19 at 9.17.45 pm.png
    Screen Shot 2017-08-19 at 9.17.45 pm.png
    125.8 KB · Views: 11