Sending slow and then stops completely

John Moylan

New Member
Been having issues with slow speed followed by a complete stop.

This issue started when I first bought Mail Wizz but then went away for a couple of weeks only to appear again yesterday and today. I have an unhappy client as a time sensitive email got stuck sending.

I send via SparkPost who claim not to have any issues.

It's getting that I cannot trust any email send and have spent part of today waiting for an email send to stutter instead of doing my day job and actually earning money!

I logged this issue before by email and sent video over when I tested using the debug cron job. You pointed at Spark Post but they deny responsibility and to be fair why would a campaign stay stuck on sending at 20% - any help gratefully received.

Thanks
John
 

John Moylan

New Member
Hello Twisted.

Yes I did, I sent the logs to you by email about a month ago if you remember - along with video output.

I have an email right now about to complete (99%) which was stuck earlier today and another one in the same account currently stuck on 40% with zero movement. Raised it with SparkPost but they're going to blame you and you'll point me at them. :( (I should add that you are far more responsive then them though. :) )
 
Last edited:

frm.mwz

Well-Known Member
Hello Twisted.

Yes I did, I sent the logs to you by email about a month ago if you remember - along with video output.

I have an email right now about to complete (99%) which was stuck earlier today and another one in the same account currently stuck on 40% with zero movement. Raised it with SparkPost but they're going to blame you and you'll point me at them. :( (I should add that you are far more responsive then them though. :) )

If you send bulk via transactional providers, they may be less responsive (or block you).
 

John Moylan

New Member
Yes, I queried this before I signed up and was assured I'd be fine with our double opted in lists.
I have a daily limit of 375,000 (far more than I need) and have only sent 45,341 in past twenty four hours.
 

frm.mwz

Well-Known Member
This issue started when I first bought Mail Wizz but then went away for a couple of weeks only to appear again yesterday and today. I have an unhappy client as a time sensitive email got stuck sending.

I send via SparkPost who claim not to have any issues.

Does not sound like a setup problem, rather like s/t that somehow emerged, maybe a certain server update, or for some reason the the connection btwn your server and sparkpost is superslow (test ping times) or something not exactly in mwz or sparkpost and a bit in btwn.
This can be hard to diagnose. What kind of a server are you using?
 

John Moylan

New Member
Pretty high spec dedicated box.
2 x Intel Xeon E5-2620 V3 CPU (24 total cores)
32GB RAM
4x 250GB Enterprise SSD Disks (RAID10)

Oh, and Linux of course.
CentOs 6 with CloudLinux running on top.
 

John Moylan

New Member
Before I PM a quick question.
Would sending two emails (via SparkPost) from the same email address/domain at the same time cause an issue? (I wouldn't have thought so but that's what I'm doing here)
 

John Moylan

New Member
On holiday with the family so apologies for terse reply.

MySQL timeouts weren't helping, have tuned database a little and given it more memory and processing. Take a look in admin panel application logs from memory.

Issue seems to have gone away but not sent multiple large emails for a while.

Support from Twisted1919 was excellent.
 
Top