Sending quota counter problem

Discussion in 'General discussions' started by dintchev, Dec 4, 2018.

  1. dintchev

    dintchev New Member

    Joined:
    May 30, 2017
    Messages:
    14
    Likes Received:
    2
    S.E:
    2019-06-07 23:48:57
    L.T:
    Regular
    L.C:
    2
    Hello guys,
    I have a problem with my sending quota customer counters. My sending quota counters "lose" sending credits. My customers had sended more emails than the counter show:(
    1) Ex.: Let's tell at Day1 my client had 30% sendeing quota which is correct > I start a new campaign at Day 1 which is sending 3 days because the list is huge > At Day 2 the counter show less (let's tell 12%) > At Day 3 is again proper guota 30%+the new sended emails.
    2) This is the main problem at most of the cases. It seems the daily cron refresh the proper quota at the next day. But even so - this is also a problem because the customer see mismatched information each day.
    3) Also a bigger problem - some of my customers "lost" their all used credits and they have a fresh counter even if they sent 90% of their quota...
    4) I know that mailwizz calculate the quota on Delivery Server Logs by the Cron. At backend I have these settings: Backend>Cron>Delivery settings>Delete delivery logs (both ways: both ways yes|no). Also Settings for processing Delivery and Bounce logs>90days|60days|5days (now it is 60 days).
    5) At my sending quota Group settingsTime value is set to "-1"

    So please give me an idea what can be the problem? Is that mean if I don't keep my old logs (older than days puted at Cron settings) I will alwys lost a sending quota? I read a comentar of twisted that there is a new function in mailwizz which one write the sended quota mails at another table at sql independently than Delivery logs but it seem it does not work at me?
     
    Last edited: Dec 5, 2018
  2. twisted1919

    twisted1919 Administrator Staff Member

    Joined:
    Dec 27, 2014
    Messages:
    9,697
    Likes Received:
    2,268
    @dintchev - You are right related quota and logs, you need to keep the logs so we can accurately count the usage. Keep in mind that the table used for counting sending quota is delivery_server_log not campaign_delivery_log. They are two different things and we do have code in place to cleanup the campaign_delivery_log table, while for the delivery_server_log we don't delete records.
    The settings at Backend>Cron>Delivery settings>Delete delivery logs apply to campaign_delivery_log NOT to delivery_server_log.

    Now, to your actual issue, you will have to provide a screenshot with the group settings for sending, i have a hunch that you are resettings the quota for a fresh start when it's reached.

    Also, a bigger problem is that i don't see you using an extended license but still having customers.
     
    dintchev likes this.
  3. dintchev

    dintchev New Member

    Joined:
    May 30, 2017
    Messages:
    14
    Likes Received:
    2
    S.E:
    2019-06-07 23:48:57
    L.T:
    Regular
    L.C:
    2
    Hello twisted1919,
    I send a screenshot for group sending:
    upload_2018-12-4_18-26-25.png

    or second example. You can see at second that I am trying to decrease the sending quota manual as watching the sended mails on statistics :oops:
    upload_2018-12-4_18-27-36.png
     
    Last edited: Dec 5, 2018
  4. twisted1919

    twisted1919 Administrator Staff Member

    Joined:
    Dec 27, 2014
    Messages:
    9,697
    Likes Received:
    2,268
    An update for this thread, i have some fault for this as i haven't properly understood what the initial issue was and because i forgot that indeed we cleanup the logs older than 90 days by default, so @dintchev #4 point should have rang bells for me, but it didn't, sorry for that.

    So, in order to keep the database smaller, we, by default, remove delivery server logs which are older than 90 days. If you have sending quotas that will last for longer than a month, then you need to adjust this setting to a higher value, depending on your use case.
    It can be adjusted from backend > settings > cron > Settings for processing Delivery and Bounce logs > Delivery servers logs removal days *
     

Share This Page