Sending issue "Cannot find a valid server.."

Dripp

New Member
Hi!
I've been installed the Mailwizz in my hostgator account (the cron jobs are all configured like the tutorial), but the campaigns stacked in the "pending" status. When i see the log, the message appears:

2016/07/30 19:01:05 [error] [application] Cannot find a valid server to send the campaign email, aborting until a delivery server is available!

When i tried to send a test mail, this worked fine.

Yes i've configured a amazon send server, and yes i assigned to a customer group.

Please help me!
 

frm.mwz

Well-Known Member
Hi!
I've been installed the Mailwizz in my hostgator account (the cron jobs are all configured like the tutorial), but the campaigns stacked in the "pending" status. When i see the log, the message appears:

2016/07/30 19:01:05 [error] [application] Cannot find a valid server to send the campaign email, aborting until a delivery server is available!

When i tried to send a test mail, this worked fine.

Yes i've configured a amazon send server, and yes i assigned to a customer group.

Please help me!

Probably either not valid anymore or some settings on amazon end need to be adjusted as well, also, see if the delivery server is chosen in the campaign.
 

twisted1919

Administrator
Staff member
@Dripp - to complete on what @Vpul Shah said, when you run PHP from cron jobs, the PHP version might differ from the one that you see in your browser, and that seems to be the case for you too, in browser you have a version, while in command line you have another.
Your hosting should be able to help correcting this issue.
 

Dripp

New Member
@Dripp - to complete on what @Vpul Shah said, when you run PHP from cron jobs, the PHP version might differ from the one that you see in your browser, and that seems to be the case for you too, in browser you have a version, while in command line you have another.
Your hosting should be able to help correcting this issue.

I tried this, but the problem persist. My php version is 5.5.
 

twisted1919

Administrator
Staff member
Are you sure you ran same php binary that is used in the cron jobs?
if you did, you can PM me with backend login and url to your app so that i can take a look.
 
@twisted1919
[error] [application] Cannot find a valid server to send the campaign email, aborting until a delivery server is available!

I am facing this error in the app status in backend/misc/application-log.

I dont have any issues in sending e-mails or dispatching e-mails. I cannot see any campaign stuck in pending. The delivery of the e-mails is good. Just don't know what can be the issue? The error is coming after every minute. Haven't used the app for a day or two, so nothing has been sent or so.
 
@twisted1919

5) You have a valid server for all emails, but the settings from Backend > Settings > Customers > Servers (same for group setting) dictate that the customer must add his own servers in order to send the emails.

This one is true. So just ignore the issue and let it occur?
 
Top