Send random email

Rouille

New Member
Hello,

what is the procedure for my emails to go randomly, because when I put yes to Randomize subscribers ,
it does not work, the emails leave in the same order !

Thank you
 

twisted1919

Administrator
Staff member
Where it says "Max Subscribers" you need to enter a number of subscribers to whom the campaign will be sent.
 

Rouille

New Member
They will leave randomly. If you set for example, 1000, then MailWizz will pick subscribers, randomly, until it reaches 1000, then it will mark the campaign as sent and stop.

Hello,
the mails still do not go randomly even following your instructions, the problem is since I use version: 2.1.5
do you think this problem is because of the version?
thank you
 

twisted1919

Administrator
Staff member
@Rouille - Can you please let me know if you are using PCNTL for sending? In Backend > Settings > Cron, in the delivery settings box, is PCNTL enabled?
 

twisted1919

Administrator
Staff member
@Rouille - Sorry for the above, I think I mislead you with the last replies.
Today I had enough time to look in the code, and here's what I found:
PHP:
// since 1.3.6.3 - because in pcntl mode we send dupes, we don't want this
if (!$this->getCanUsePcntl() && $campaign->option->getCanSetMaxSendCountRandom()) {
    $criteria->order = 'RAND()';
}
The comment says that if PCNTL is enabled, we don't randomise because if we do it, there's a chance we pick same subscriber twice or more which would lead to sending duplicates.
So randomisation will only work when PCNTL is disabled, otherwise, we would send duplicate emails.
 

Rouille

New Member
@Rouille - Sorry for the above, I think I mislead you with the last replies.
Today I had enough time to look in the code, and here's what I found:
PHP:
// since 1.3.6.3 - because in pcntl mode we send dupes, we don't want this
if (!$this->getCanUsePcntl() && $campaign->option->getCanSetMaxSendCountRandom()) {
    $criteria->order = 'RAND()';
}
The comment says that if PCNTL is enabled, we don't randomise because if we do it, there's a chance we pick same subscriber twice or more which would lead to sending duplicates.
So randomisation will only work when PCNTL is disabled, otherwise, we would send duplicate emails.
Hello,
Thank you very much for your customer service!
do you know why each campaign sends around 130k per day instead of 50k?
here are the configurations attached
Thank you
 

Attachments

  • Settings.pdf
    133.6 KB · Views: 4
  • Update server.pdf
    110.1 KB · Views: 4

twisted1919

Administrator
Staff member
yes I choose a server for each campaign,
This means that MailWizz will use that delivery server as long as it's over quote. Once it reaches the quota, if MailWizz finds another delivery server to deliver your emails, then it might use other delivery servers as well, more precisely, system delivery servers, if the customer is allowed to use system servers to send emails, so if you want to block this behavior, in backend > settings > customers > servers (or in the group settings), you will have to set it so that customers cannot send emails from the system servers.

Now looking at all this, maybe the correct approach when a campaign has selected delivery servers and then those server hot a quota, would be to simply pause sending until those servers are available again. This means the delivery would be delayed considerably, so I don't know if this would actually be the right choice.
As we have it now, at least you get to deliver all your emails if there are delivery servers available, so I don't know, I am open to dicussions related to this.

Meanwhile, @laurentiu - can you test the above and see if system servers are used if campaign assigned servers quota is consumed?
 

jacobrosenfeld

New Member
@Rouille - Sorry for the above, I think I mislead you with the last replies.
Today I had enough time to look in the code, and here's what I found:
PHP:
// since 1.3.6.3 - because in pcntl mode we send dupes, we don't want this
if (!$this->getCanUsePcntl() && $campaign->option->getCanSetMaxSendCountRandom()) {
    $criteria->order = 'RAND()';
}
The comment says that if PCNTL is enabled, we don't randomise because if we do it, there's a chance we pick same subscriber twice or more which would lead to sending duplicates.
So randomisation will only work when PCNTL is disabled, otherwise, we would send duplicate emails.
That's annoying. Any chance this was fixed?
I knew my randomizing broke at some point. This explains it...
 
Top