Send Error After Upgrade

Dan O'Shea

I upgraded last week and tried sending my first campaign today. Using both the Amazon SES server and through my site's email server, the program sends but none are delivered and it simply states ERROR.

I did not change any email server settings and don't want to as I'm thinking both Amazon and Site servers are not the issue but a PHP or script error after upgrading.
Hi Dan,
Have you tried looking in the Backend -> Misc -> Campaign Delivery logs area? Do you spot any message there that could help?
You could also try to force delivery servers revalidation (just change the username, save changes, then change the username back and validate)
Lemme know how it goes.
Also, I logged into Amazon SES and sent a test mail and it was successful.

Ok, I'm getting delivery errors for both Amazon SES and my Site email server. I have not changed any server settings and since it is two servers giving me an issue, I don't think that is the problem. The last successful send was on 9/1/2015 before the upgrade with both these servers. Below are the errors from both servers.:

Amazon SES:
"Error retrieving credentials from the instance profile metadata server. When you are not running inside of Amazon EC2, you must provide your AWS access key ID and secret access key in the "key" and "secret" options when creating a client or provide an instantiated Aws\Common\Credentials\CredentialsInterface object. ([curl] 28: Connection timed out after 5024 milliseconds" using 2 possible authenticators"
Hi Serban,

FYI, for any future search, one of my email addresses (one I don't use) on the domain was compromised and was sending out tons of spam email so the server automatically shut down. It actually does protect the domain from being put on blacklists.
So Bluehost had me change email passwords and I actually deleted that address, they cleared out the server and reactivated the email server.
Your script is so smooth I didn't think it was a PHP issue so I at that point, I thought there was an issue with the server and called Bluehost and found out about the one email address being accessed.

I still have the sending error. I've spent almost all day with Bluehost. Here is the timeline starting last week:
9/9 - Upgraded program, did not send any campaign.
9/16 (today) - Breach in an email
All email on the domain was shut down. I deleted the email and Bluehost opened up the email send ability again.

I tested and sent email from successfully from my Thunderbird client using the smtp protocol of Bluehost.
I was able to log in and send email successfully using Bluehost's webmail on
I tested and sent from the same email address on Amazon SES, so I know that is working too.
So both the SMTP and Amazon SES are working separate from Mailwizz.

I went into the backend of Mailwizz and tried to validate the SW Jets server -
Bluehosts settings are:
PASSWORD - *****
PORT: 465
The above is all the same as my Thunderbird settings that work and verified as the correct settings from Bluehost technical support.
It still didn't work and they sent me to level II. They looked into a number of areas and finally believed it could be a permission issue in the script they wouldn't know about or some other issue related to the application.

I then decided to try and add a new server with another separate account I have with Bluehost on
I tried adding and with the same settings except for the respective HOST, USER and PASSWORD, I couldn't Validate on that server either.

With the fact I can't Validate on multiple servers or emails and can't send either with SMTP or Amazon when they are working separate from Mailwizz, I'm of the belief that it has to be an issue with the upgrade. File permissions or something else?

[Pulling my hair out...]