Scheduling Campaign time offset

Spiro

Member
Hi,

Some of my customers are in different time zones than my server time. When they schedule a campaign for sending it sends at the server time, and not their local time.

I have setup their time zone correctly, and use the time/date picker. I am running version 1.3.6.5

See the attached file.

Thanks
 

Attachments

  • Capture.JPG
    Capture.JPG
    53.9 KB · Views: 18

Spiro

Member
I managed to sort it out. For some reason our server time was out of sync. In case anyone is interested in sorting this out in the future i just added this to the cron.

00 9 1 * * root ntpdate time.nist.gov >/dev/null

It just updates the server time once a month.
 

rritz

Member
Can I also just run this command once to try and see if it helps with my problem?
Just make ssh connection and run the command? Or do I have to be careful with this?
I don't know anything about the commands in ssh so please excuse me if this is a stupid question
 
Last edited:

twisted1919

Administrator
Staff member
@rritz :

First you have to make sure ntpdate is running:
Code:
systemctl start ntpdate

Then you have to sync:
Code:
ntpdate -s time.nist.gov

Here's where i tried:
Screenshot 2016-10-28 14.12.34.png
 

rritz

Member
Hi, thank you for trying to help.
I get a command not found for systemctl
I can sync, the output time is Sat, Oct 29 06:29:41 BRST
which is I think a timezone for the westernmost part of Alaska, Ardak
So I set my timezone in php.ini to America/Ardak
and also in customer and backend profiles
back to scheduling a campaign,
the system time in mailwizz is now Fri, Oct 28 11:29 pm

If I could understand where the times are coming from? Where does MW take the time from? Where does the server take the time from?
What does php.ini timezone settings actually do?
I thought, if I set my timezone in costomer profile, then mw would know, I am in Europe, and get my local time, so that I can schedule campaigns easier. But I set one timezone and mw shows completely differennt one...

I am sorry, maybe these are very stupid questions but I have never done anything with bash commands or in php
I just got a script and installed it on the server. For everyone who bought the script everything went just fine.
Only for me, not. :) So I asked the guy who wrote the script what to do, and he told me to change php.ini
I did, I tried all sorts of combinations, and the problem persisted.
Maybe, if I could understand how the time settings should work Ii would understand what's going wrong here
 
Top