RSS feed won't register

Suddenly, after successful use of the RSS feed function for many months, the system doesn't register the RSS feed on new posts. I've checked and cleared the cache, checked syntax, and reviewed recent updates and so far can see no reason for the problem.

Can you help?
Can your domain where mailwizz is installed access the rss feed domain?
If you send a test campaign, still does not work?
If you rename the apps/common/runtime/cache folder into /apps/common/runtime/1.cache (so that a fresh one be created with fresh info, you could as well remove that folder but takes ages), does it fix the issue?
In answer to the first two questions; The domain/site hasn't changed in the past week, and the RSS feed function has worked well until now.
Test campaigns do not work.
I renamed the cache file as recommended above, and that didn't solve the problem.
Well, something has to change in order to break the things, otherwise it would work.
When you say it doesn't work, you get the email with the RSS feed tags unparsed or what exactly do you get?
can you do a test and put here the link to the test result?
mail-tester seems okay

One possibility is a software update to one or more of the wordpress plugins perhaps the security plugin (wordfence), but I tried removing all plugins and reinstalling and other measures at that end, without any success, and can't find any references on the web to validate that is the problem.
Ahh, I was able to track down the problem with
It seems one of my posts had some syntax structure/errors -- I couldn't find the specific error caught by the validator on the site, but when I removed the offending post, the RSS generator resumed working.