Recurring campaign set to send every 1 minute, but next queued campaign send @ top of next hour

Discussion in 'General discussions' started by p. bateman, Jun 20, 2018.

  1. p. bateman

    p. bateman New Member

    Joined:
    Oct 19, 2017
    Messages:
    25
    Likes Received:
    1
    S.E:
    Expired
    L.T:
    Regular
    L.C:
    1
    Hello!
    I've setup a recurring campaign to send every 1 minute and after clicking send, I see that the next queued campaign to send is not at `previous send time + 1 minute` as expected but rather it's at the top of the next hour, 10 pm in this case.

    See the attached for what I mean. Is this a bug or am I doing something wrong?

    Additional background:
    The email is set to send every 1 minute because it's going to a segment that's defined by custom fields that an external app is updating whenever a subscriber makes a purchase. This email is basically transactional and should send at the time of purchase.
     

    Attached Files:

  2. p. bateman

    p. bateman New Member

    Joined:
    Oct 19, 2017
    Messages:
    25
    Likes Received:
    1
    S.E:
    Expired
    L.T:
    Regular
    L.C:
    1
    Update: 10pm has just passed here and now the next scheduled campaign in the queue is 11pm. So it appears that despite setting the campaign to recurring send every 1 minute, it's actually saving as sending every 1 hour.
    Screen Shot 2018-06-19 at 10.07.44 PM.png

    Attached is the configuration I have before clicking `send campaign`.
    Screen Shot 2018-06-19 at 10.31.15 PM.png

    Can someone please help me fix this bug.
     
    Last edited: Jun 20, 2018
  3. laurentiu

    laurentiu Member Staff Member

    Joined:
    Mar 13, 2018
    Messages:
    134
    Likes Received:
    18
    @p. bateman - Recurring setting -> "Every hour at 0-59 minute(s) past the hour" (select manually all minutes from 0 - 59)
     
  4. p. bateman

    p. bateman New Member

    Joined:
    Oct 19, 2017
    Messages:
    25
    Likes Received:
    1
    S.E:
    Expired
    L.T:
    Regular
    L.C:
    1
    @laurentiu oy, your recommendation is to manually configure 59 recurring campaigns, each with a different minute interval, 0-59? That's a horrifically manual workaround.

    Can you please fix the "recurring every x minute" UI component so this works as expected?
     
  5. laurentiu

    laurentiu Member Staff Member

    Joined:
    Mar 13, 2018
    Messages:
    134
    Likes Received:
    18
    @p. bateman - You need to create only one campaign and on advanced recurring setting you need to set -> "Every hour at 0-59 minute(s)".
    When i said to select manually all minutes from 0 - 59 i meant to select all minutes in witch your email must be sent.
    Screen Shot 2018-06-21 at 9.20.30 AM.png
     
  6. markmaster

    markmaster New Member

    Joined:
    Oct 28, 2018
    Messages:
    1
    Likes Received:
    0
    S.E:
    2019-04-11 03:50:34
    L.T:
    Regular
    L.C:
    1
    Im having the same issue, its annoying i have to select 60 numbers instead of just choosing "every minute"...
     

Share This Page