Problems with list redirects

Stratagem

New Member
Hello,

I have a few problems with the redirects for "Sub. not found redirect" and "Sub. exists redirect". I'm marketing some campaigns redirecting through Hasoffers with multiple custom tags.

First, when I save the Update List form, any "&" gets replaced with "&". The problem here is that the links break on redirect. While it isn't convenient, I have gone into the database and replaced the "&" to get the URLs right.

However, even when I do this, the custom tags aren't being replaced during the redirect through MW. (Note that in the screenshot below I show the URLs as fixed in the database.)


mw_redirects.png

When I submit the same email twice I end up here (no tags replaced):
http://track.domain.com/aff_c?offer_id=1788&aff_id=&aff_sub=&aff_sub2=


Perhaps "common custom tags" means only the default tags rather than any custom tags.

Anyone else having this problem?

I will note that the URLs save and work fine when I use them to replace pages such as Subscription confirmed.

Please let me know if this is a bug or it is simply not currently available.

Thanks.
 

twisted1919

Administrator
Staff member
Hi :)

First, when I save the Update List form, any "&" gets replaced with "&". The problem here is that the links break on redirect. While it isn't convenient, I have gone into the database and replaced the "&" to get the URLs right.
This used to be a problem in the past, but newer versions of the app don't have it anymore, i tried the dev now and i can't reproduce the issue, so is fixed. What version of the app you're using ?

However, even when I do this, the custom tags aren't being replaced during the redirect through MW. (Note that in the screenshot below I show the URLs as fixed in the database.)
There's no reason to put tags in the 404 redirect field because no tag is replaced for that field.(if the subscriber doesn't exists, from where to take those tags which are specific to the subscriber...?)
We only replace for when the subscriber exists, so that should work just fine for you in your example, though we don't remove the tags if we don't find replacements for them, so i am not sure why your tags are empty in the above example, again, what version of the app are you using ?
 
Top