Problem sending using MW 1.5.1 and Mailgun

Dan G

New Member
I've installed MailWizz on a dedicated server with LAMP. PHP version 7.1.12. When I try to send a campaign it just sits at 0% forever. I've checked my view cron jobs history and send-campaigns have a success status so I know the cron is running. I even thought about the time zone and set a campaign to start from a day ago and still no luck.

I then decided to look at Mailgun and all looks good. I even received the email to validate the server when I entered the API information for Mailgun and it validated correctly.

Not sure what else I can do.

Any ideas?

I ran the cron in verbose and received the following ...

[2018-01-05 18:36:29] - Campaign Worker #0 looking into the campaign with ID: 11
[2018-01-05 18:36:29] - This campaign belongs to Test Test(uid: os805yk6bj41d).
[2018-01-05 18:36:29] - Changing the campaign status into PROCESSING!
[2018-01-05 18:36:29] - Cannot find a valid server to send the campaign email, aborting until a delivery server is available!Campaign UID: cp191zwgqw9bb

I checked and my customer is set to use the Mailgun server under Assigned Server and the Mailgun server is validated. Am I missing anything elsewhere?
@Dan G - I think the issue is, that your PHP version from command line is lower than the PHP version from the web server.
You can view the web server version from backend > misc > php info.
You can view the php version from command line by running /usr/bin/php -v from command line. /usr/bin/php might not be the right binary path in your case, use the same php binary as the one you used above to debug the send campaigns command.
So do that and let's see the results.
Great Catch!!! Within Plesk even though a website is using PHP 7.1, the cron path still points to an older version. I corrected the cron jobs to use /opt/plesk/php/7.1/bin/php and all works great now.

Thanks so much!!!!