Pending-send the cron not works only for mailwizz

roland

Member
Hello,
I am in shared hosting. I tested sendmail that works, I already added API sparrkpost, this API I tested it in local with swiftmailer it works.

I tested the cron with a php file that send an email and it works but when I add mailwizz crons it seems that not works because I d’ont recevie any email about Cron.

I tested :
* * * * * /usr/bin/php-cli -q /home/.../public_html/mailwizz/apps/console/console.php send-campaigns
and
* * * * * php -q /home/.../public_html/mailwizz/apps/console/console.php send-campaigns

that not works.

I tested the cron with a file send.php
* * * * * php -q /home/.../public_html/send.php
that works, that means the problem is not a cron.

I don't used >/dev/null 2>&1 to receive an email when cron is executed.

I receive email that the file send.php (my file of test) but I don't receive any email about mailwizz/apps/console/console.php send-campaigns.

Thank you.
If their is an admin I can give him in PM the access of my mailwizz and cpanel to check.
 

frm.mwz

Well-Known Member
Hello,
I am in shared hosting. I tested sendmail that works, I already added API sparrkpost, this API I tested it in local with swiftmailer it works.

I tested the cron with a php file that send an email and it works but when I add mailwizz crons it seems that not works because I d’ont recevie any email about Cron.

I tested :
* * * * * /usr/bin/php-cli -q /home/.../public_html/mailwizz/apps/console/console.php send-campaigns
and
* * * * * php -q /home/.../public_html/mailwizz/apps/console/console.php send-campaigns

that not works.

I tested the cron with a file send.php
* * * * * php -q /home/.../public_html/send.php
that works, that means the problem is not a cron.

I don't used >/dev/null 2>&1 to receive an email when cron is executed.

I receive email that the file send.php (my file of test) but I don't receive any email about mailwizz/apps/console/console.php send-campaigns.

Thank you.
If their is an admin I can give him in PM the access of my mailwizz and cpanel to check.
In case you still have the problem
just find out on ssh command line where your php and php-cli really are with
which php
which php-cli
then use that in your cron
 
Top