No bounces or feedbacks

Discussion in 'Common issues' started by avidns, Jan 3, 2019.

  1. avidns

    avidns New Member

    Joined:
    Dec 24, 2018
    Messages:
    14
    Likes Received:
    1
    S.E:
    2019-03-30 10:39:31
    L.T:
    Regular
    L.C:
    1
    Hi!

    So I started rolling out my IP warm up a few days ago and so far everything seemed fine. I thought it was weird that I wasn't seeing any bounces or complains but thought maybe the slow speed plus it was my actives list was playing a positive roll.

    Earlier today I decided to dig into my MTA and saw logs were being generated for them but MW was not processing them.

    I've checked and rechecked my inbox settings for my bounces server and even ran test emails to the inbox and everything seemed like it was working.

    I decided to give this a shot: https://github.com/magicdude4eva/port25-bouncehandler
    And finally got it working. Processed the first batch that was generated and it seemed like it worked. But again, in the backend of MW... nada.

    Can anyone give me some insight, maybe something to read up on? Why wouldn't bounces be getting worked out and put into the MW system?
     
  2. twisted1919

    twisted1919 Administrator Staff Member

    Joined:
    Dec 27, 2014
    Messages:
    9,784
    Likes Received:
    2,301
    @avidns - the way pmta processes the bounces is very different and this is why you need a special tool like the one you linked, which takes the bounces from pmta and using mailwizz's api, send the bounces to mailwizz.
    If you get nothing to mailwizz, maybe double check the API credentials you used for the above library.
     
  3. avidns

    avidns New Member

    Joined:
    Dec 24, 2018
    Messages:
    14
    Likes Received:
    1
    S.E:
    2019-03-30 10:39:31
    L.T:
    Regular
    L.C:
    1
    AH I see! That's vital intel, thank you @twisted1919 !!!
     
  4. avidns

    avidns New Member

    Joined:
    Dec 24, 2018
    Messages:
    14
    Likes Received:
    1
    S.E:
    2019-03-30 10:39:31
    L.T:
    Regular
    L.C:
    1
    OK it looks like my relay can't talk to my mailwizz install:

    [03/Jan/2019 17:08:41] Endpoint-URL=http://wizz.avidsender.com/api
    [03/Jan/2019 17:09:13] Failed connecting to http://wizz.avidsender.com/api, check conncetivity!

    And I see no reason for it to not. I've got the IP address whitelisted within the API settings.

    The public and private keys are correct. When I attempt to manually process the bounces, it takes an extra few seconds on the above-mentioned portion.
     
  5. twisted1919

    twisted1919 Administrator Staff Member

    Joined:
    Dec 27, 2014
    Messages:
    9,784
    Likes Received:
    2,301
    If you allow all IPs to the api, does it work ?
     
  6. avidns

    avidns New Member

    Joined:
    Dec 24, 2018
    Messages:
    14
    Likes Received:
    1
    S.E:
    2019-03-30 10:39:31
    L.T:
    Regular
    L.C:
    1
    It doesn't, I've tried. and as far as I can tell in my iptables, the servers can talk to one another.

    edit:

    I just realized you said "all ips" -- maybe I haven't. How do I do that? by removing the whitelisted IP? If so, yes I have tried that.
     
  7. avidns

    avidns New Member

    Joined:
    Dec 24, 2018
    Messages:
    14
    Likes Received:
    1
    S.E:
    2019-03-30 10:39:31
    L.T:
    Regular
    L.C:
    1
    Alright, ignore me here. The relay's OWN firewall was stopping it from talking to MW... I'm not an expert sysadmin but I've never seen something like that before.
     
    twisted1919 likes this.

Share This Page