new domain suffixes (do they work)

Recently, someone tried to sign up for our eletter with a .build domain suffix. Although all the details appear in order, I'm getting an error "Email is not a valid email address." Is it possible the system hasn't been updated to allow for the many new suffixes, including ones that go beyond three letters?

Otherwise, what could be the problem?
 
Both when I try to enter the name manually and when the subscriber tries to login through the login form.

She contacted me to see what was happening. I found that she had a valid registration with a .com suffix, as well, and that one bounced also (but that could be explained as an "already subscribed" situation.
 

Rob

Active Member
You seem to be confusing a subscription with a registration. Do you mean when someone tries to subscribe to a particular list or do you mean when someone tries to register to use your MW installation as a customer?
 
I mean trying to subscribe to a list.

Frankly, this is the first time I've come up with this problem -- other list subscription requests seem to work okay, though I might not know if they failed. In this case, the reader contacted me directly. The address appeared valid, and then I ran into the same error when I tried to input it manually. I then found the other ".com" address in the system as an already-valid subscription (the email address is totally different so should not overlap.)
 

Rob

Active Member
OK, in that case it is a bit weird. I've just done a quick test on a couple of lists and I didn't see that error. I used a .email & .build suffix.

Can you try a different list and see what happens?

Are you seeing the error when using the list subscribe URL similar to this www.yourdomain.com/lists/nb645222qy308/subscribe
 
Top