Mysql crash on 1.5.0: (core dumped) /usr/bin/php -q


I installed mw 1.5.0 on my server: 24 GB RAM, 6 cores CPU, 600GB SSD storage, CentOS 6.9
I had two instances of mw 1.4.3 running fine on the server. I tried to update one of them, but failed. So I completely removed the one instance of mw plus database and installed 1.5.0
I was just adding the bounce and sending servers, when I got logged out.

On trying to log in, I got an error, that mysql needs more memory
I logged into the server on SSH and got a notice to my root mail:

/bin/sh: line 1: 14578 Aborted (core dumped) /usr/bin/php -q /var/www/html/a/apps/console/console.php send-campaigns > /dev/null 2>&1

and several similar messages with the various cron jobs I added

I have no idea at all what happened. What does it mean, core dumped?

Now, when I try to log in to mw, I get a blank page only, on both mw installations
/bin/sh: line 1: 14578 Aborted (core dumped)
This means PHP died for some reason when it tried to run the command, memory usage might have something to do with it.

Now, when I try to log in to mw, I get a blank page
Enable debug. This will tell you what is going on.

Now, do you have htop installed on your server( )? If you do, run it and take a screenshot of it so we can see the server usage.
debug shows: Fatal error: Out of memory (allocated 1835008) (tried to allocate 72 bytes) in /var/www/html/apps/common/framework/YiiBase.php on line 475
after reload:
Fatal error: Out of memory (allocated 8388608) (tried to allocate 32 bytes) in /var/www/html/a/apps/common/framework/caching/CCache.php on line 108

and various other php files after various reloads

What memory would that be? Is it something in php.ini or some setting in mysql? I have been using mysqltuner to optimize settings, but have not done much with php settings

I can not install htop, I get a lot of errors

File "/usr/bin/yum", line 29, in <module>
yummain.user_main(sys.argv[1:], exit_code=True)
File "/usr/share/yum-cli/", line 298, in user_main
errcode = main(args)
File "/usr/share/yum-cli/", line 146, in main
result, resultmsgs = base.doCommands()
File "/usr/share/yum-cli/", line 440, in doCommands
return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
File "/usr/share/yum-cli/", line 211, in doCommand
return base.installPkgs(extcmds)
File "/usr/share/yum-cli/", line 702, in installPkgs
File "/usr/lib/python2.6/site-packages/yum/", line 3555, in install
mypkgs = self.pkgSack.returnPackages(patterns=pats,
File "/usr/lib/python2.6/site-packages/yum/", line 907, in <lambda>
pkgSack = property(fget=lambda self: self._getSacks(),
File "/usr/lib/python2.6/site-packages/yum/", line 687, in _getSacks
File "/usr/lib/python2.6/site-packages/yum/", line 295, in populateSack
File "/usr/lib/python2.6/site-packages/yum/", line 110, in doSetup'postreposetup')
File "/usr/lib/python2.6/site-packages/yum/", line 184, in run
func(conduitcls(self, self.base, conf, **kwargs))
File "/usr/lib/yum-plugins/", line 202, in postreposetup_hook
all_urls = FastestMirror(all_urls).get_mirrorlist()
File "/usr/lib/yum-plugins/", line 369, in get_mirrorlist
File "/usr/lib/yum-plugins/", line 413, in _poll_mirrors
File "/usr/lib64/python2.6/", line 474, in start
_start_new_thread(self.__bootstrap, ())
thread.error: can't start new thread
no mem for new parser
Error in atexit._run_exitfuncs:
Traceback (most recent call last):
File "/usr/lib64/python2.6/", line 24, in _run_exitfuncs
func(*targs, **kargs)
File "/usr/lib/python2.6/site-packages/yum/", line 176, in run
conduitcls = eval(conduitcls) # Convert name to class object
Error in sys.exitfunc:
Traceback (most recent call last):
File "/usr/lib64/python2.6/", line 24, in _run_exitfuncs
func(*targs, **kargs)
File "/usr/lib/python2.6/site-packages/yum/", line 176, in run
conduitcls = eval(conduitcls) # Convert name to class object
I think what happens is that your other app is consuming all the resources.
Can you put it offline so the memory usage will lower ?
I can't because I get the same errors
ok, I'll have to remove one instance again
why would two instances of 1.4.3 work fine and 1.4.3 and 1.5.0 crash? Is 1.5.0 using that much more resources?
Nope. Overall using two instances on same server is a terrible bad idea.
yes I understand, but with one licence I can only test new version on the same server.

But I had also two instances running on a small 4GB RAM server, I had to take one of them offline that's true, but no crashes like this one here

What is it that is using the resources? I have no campaigns running at the moment. I disabled almost all cron for one of the installation already before I started the second instance. I have to keep the first instance intact for campaign logs and stats, and seubscriber logs and lists. I don't need to send any email through it. But I need access to subscriber info, and list custom fields etc. If I take the instance offline, I cannot access frontend, and therefore cannot access sub info, list info etc.

So, with cron disabled, what is still using ressources?
So, with cron disabled, what is still using ressources?
I\d have to look and see, i can't tell from the top of my mind, but remember it takes a while for crons to finish processing after you have stopped them.
Can you show a screenshot with the sending settings from backend > settings > cron ?
If you give plenty of RAM and time for the php variables, have php 5.6+ on the server (better php 7.1) and MariaDB with proper settings, it should not get into trouble. The only thing that can max out/slow down the server then should be the parallel processes (so if you start with low numbers there and notch it up step by step, you might find a spot where your apps can coexist running).