Migrating to Lightsail Instance and Getting Error


I am trying to migrate over to a lightsail instance. I use the mailwizz backup plugin which copies the files and the database to my s3 bucket. Using the following link below https://www.mailwizz.com/kb/migrating-mailwizz-to-a-new-server/ I was able to to migrate it to a proxmox vm with ubuntu 20.14 (PHP 7.4.3) as a test and had no issues.

With the same backup file I went to lightsail and created an instance. I chose a lamp server with php8 as shown below:
Screenshot 2023-11-18 at 6.46.26 PM.png

Screenshot 2023-11-18 at 6.47.43 PM.png

After all is said and done I get the following error when i visit the page.

Screenshot 2023-11-18 at 6.53.13 PM.png

I tried it two times using the same lightsail setup then deployed an EC2 instance for a total of 3 attempts and got the same result.

Could it be because of the php8?

PHP 8.2.12 (cli) (built: Nov 11 2023 18:25:36) (NTS)
Copyright (c) The PHP Group
Zend Engine v4.2.12, Copyright (c) Zend Technologies
    with Zend OPcache v8.2.12, Copyright (c), by Zend Technologies
Nevermind. I went back to the orginal server and disabled bulk email checker extension and then ran the backup again. It installed to my new server with no issues.
Well I thought it was working because the mailwizz homepage loaded up. But when I try to login now I get a different error.

Screenshot 2023-11-18 at 9.00.43 PM.png
ok. So I finally got it to work. What I did was on my original server i updated from 1.9.48 to 2.3.8. Then I did a backup and restored it to my new lightsail instance.