MailWizz finds that 264 - 5 = 12

Britt Malka

Okay, so I'm creating a segment, and I don't understand what goes wrong.

I have 264 subscribers on that list. 5 have the content VANQUISHER in a field named VANQUISHER. When I make a segment and choose "VANQUISHER is VANQUISHER" MailWizz gives me 5.

But when I make a segment and choose VANQUISHER is not VANQUISHER" MailWizz gives me 12.

I've tried "any" and "all" and I've tried "do not contain" and "do not end with" and it keeps giving me 12 results.

With subscribers list (first page) and results after you created list segment (hide emails and other stuff in your PS is enough to see status and field named VANQUISHER).
Status doesn't show in the final filtered version, because it's a segment. But here are the images:







Except for the two subscribers at the top (new ones), everyone in the segment are tagged with "winvanquisher" in the correspondent field.

And when I filter the WINVANQUISHER subscribers, I get exactly 12.
@Britt Malka - In your segment wen you want to see only subscribers with content "VANQUISHER", add two fields:
- vanquisher is VANQUISHER, and winvanquisher is not WINVANQUISHER.
If want to see only subscribers with content "WINVANQUISHER" , add two fields:
- vanquisher is not VANQUISHER, and winvanquisher is WINVANQUISHER..
That won't work, @laurentiu , because the subscribers marked WINVANQUISHER wanted to win it. Some of those who wanted to win, bought after a winner was drawn, and then they have both WINVANQUISHER and VANQUISHER.

And as for the filter, I wanted to send an email to all who didn't buy vanquisher, and thus don't have the tag VANQUISHER, whether or not they tried to win it.
@Britt Malka - For best results on your segments you need to sync list. You can do this manually, or you can activate cron to do this from: backend > settings > cron > Subscribers settings > Custom fields sync , change this setting to Yes and wait 1 hour(this cron run every 1 hour).
If you want to do manually you need to run > sync-lists-custom-fields from command line.
Are you sure about this? The help text says that it will populate all the fields with their default settings.

I have a field, VANQUISHER. Its default setting I suppose is VANQUISHER, but I only add that text to the field when a person buys.

It sounds like syncing would add VANQUISHER to all those fields, no matter if the person had bought or not.
I was wrong. Default settings was empty. So I ran the sync, and I still only get 12 results. Nothing changed, still a problem.
Try with --verbose=1 at the end (sync-lists-custom-fields --verbose=1) and check if you have errors. From our tests sync works fine and segmentation is done correctly.
I'm sorry, you lost me here. Where do I add that? Ah, nvm found it. It's in the Run command. I cannot run a commandline.