Mailgun/Mandrill delivery servers stopped delivering

Ian Walker

New Member
Hello!

Mailwizz has been working great for me .... up until 8pm last night.

"View delivery servers usage logs" seem ok and "View campaigns delivery logs" show as email status as "Success". But emails are not being delivered. Campaign sending is as quick as ever.

Have set up the the delivery servers again, and the validation email arrives. But test campaigns from customers are not landing in my inbox and Mailgun/Mandrill stat counters don't show./ increase (apart from the validation emails). No record.

Have tried switching the server firewall off. No effect.

Any ideas what could be wrong? Thanks all :)
 

Ian Walker

New Member
I should add it's not just Mailgun/Mandrill

Set up a normal smtp server ..... activation email comes through fine.

Campaigns however show as sent ... but nothing :(
 

Ian Walker

New Member
Hi and thanks for the reply

Running mailwizz version 1.3.5.2 and PHP version 5.4.41

I managed to get this working again.by running the redis queue command (sends the emails), killing kill the queue process. and setting up the nohup.

But only 1 customer account works. The other using a different server still doesn't send.

But it's causing me some server load issues and assume this is why the service stops (upto 20/30), and as you can probably tell I don't really know what I'm doing!! Was a bit of a miracle I was able to install redis and enable pcntl :eek:

So assume just reducing the amount of workers alone is the first step to reduce server load? Would increasing the interval setting help? I appreciate sends won't be as quick.

Thanks
 
Last edited:

twisted1919

Administrator
Staff member
Hey,

I really think that running Redis with the entire queue mechansim should be done if you know your way around a linux system pretty well, otherwise there are things that can go very wrong and redis stuff is out of my expertise area.
How about you disable all this redis stuff and instead you use the send parallel campaigns daemon ?
You won't get that much speed as with redis, but at least you will be able to control the process easier.

If the above is not an option, tell me how exactly you started the queue command? What are the params, all of them?
Also, in Backend -> Settings -> Cron, what are your params?
 
Top