Lost words in translation files

nicodd17

New Member
Hello there!
I manage to create all the language files following the instructions in https://kb.mailwizz.com/articles/how-translation-works/, but after almost translate everything in spanish, I found that there is a few phrases and words that can't be found in the translation files.
I manage to insert a lot of them manually into the translation files, but some of them they don't work no matter what.
Anyone have an idea why this is happening and how I can fix this?
I'm going to upload a couple of pics to show some things that I can't translate.

Cheers!
 

Attachments

  • 1.jpg
    1.jpg
    69.5 KB · Views: 11
  • 2.jpg
    2.jpg
    56.9 KB · Views: 11

twisted1919

Administrator
Staff member
@nicodd17 - have you tried using the command line to generate the messages?
That is absolutely the best way to make sure no message gets lost.
 

twisted1919

Administrator
Staff member
See first block of text from https://kb.mailwizz.com/articles/how-translation-works/ :
Since version 1.3.6.9 we introduced a console command that you can run in order to generate all the translation files at once.
The command name is translate and can be used as follows:

-bash-4.2$ /usr/bin/php /absolute/path/to/apps/console/console.php translate
Please provide the language name(i.e: English) : Romanian
Please enter the 2 letter language code(i.e: en) : ro
Please enter the 2 letter region code(i.e: us). This is optional, leave empty if you are not sure. :
Do you agree to create the translation messages in: /var/www/vhosts/domain.com/httpdocs/apps/common/messages/ro ? (yes|no) [yes]:

Above command will create all the proper files needed for translation and it will also create the language in the web interface.
 

twisted1919

Administrator
Staff member
I did so, and then create a file in which I performed the translation, but the data file does not have some lines
The way the above command works is that it opens each file from mailwizz and it looks for translation strings and stores them, so the chance for missing lines are very thin if you ask me.

Anyway, i attached the en folder that i have just generated, you might want to take it's files and translate them if it's easier for you that way.
 

Attachments

  • en.zip
    120.8 KB · Views: 5

aleksandrwm

New Member
Translated email_blacklist.php file, there is a line
'{app} is an email-marketing service that serves companies of all shapes and sizes.' => '{app} Сервис легального email маркетинга',
'We take abuse reports seriously, if you believe a customer is sending unsolicited and or spam email, please report abuse immediately.' => 'Мы очень серьезно относимся к спаму если Вы считаете что автор рассылки прислал Вам спам, пожалуйста сообщите нам',
'By completing the form above you will permanently block your email address from receiving any email from {app} customers for the foreseeable future. This could also block genuine emails that you do want to receive from companies or websites that use our service.' => 'Заполнив форму выше ваш e-mail навсегда будет добавлен в список запрещенных адресов. После чего не один из наших авторов не сможет отправить вам письмо',
'Block my address' => 'Заблокировать мой адрес',

but on the page anyway, the English text

2017-01-17_15-33-11.png
 

twisted1919

Administrator
Staff member
@aleksandrwm - Can you please make the russian language as the default app language? That should fix this particular issue.
(you do this from you languages list, set the default to yes for russian).
 

aleksandrwm

New Member
@aleksandrwm - Can you please make the russian language as the default app language? That should fix this particular issue.
(you do this from you languages list, set the default to yes for russian).

Russian I have already been established as the main2017-01-18_00-56-37.png

these places where everything remains in English even more, as an example of what I showed

Here are a half-Russian, and some lines in English
2017-01-18_01-04-34.png
 
Last edited:

twisted1919

Administrator
Staff member
I think actually this is a bug...
Can you unzip attached archive and put the resulted .php file in/apps/common/components/init/ to overwrite existing one with same name, then try again?
Let me know how it went.
 

Attachments

  • SystemInit.php.zip
    3.6 KB · Views: 3

aleksandrwm

New Member
I think actually this is a bug...
Can you unzip attached archive and put the resulted .php file in/apps/common/components/init/ to overwrite existing one with same name, then try again?
Let me know how it went.
After replacing the file, it worked, thanks
 

twisted1919

Administrator
Staff member
See attached, make sure you put it in /apps/common/components/init
Also please make sure you have a default language set (i.e: russian is set to YES as default).
 

Attachments

  • SystemInit.php.zip
    3.6 KB · Views: 2
Top