Lists Filter Issue

Eric535

Member
So when I go to my Lists>All Subscribers>Filters, I go down to Campaigns action and choose did not open. Then I select all my campaigns from the drop down and for days I choose 30 and hit submit. But after hitting submit I get the error "This site cannot be reached". If I chose one or two campaigns then it works. But not when I choose all of them.

What should I do?
 

ghimes

Member
Staff member Support Staff
Hello!
It seems that the number of subscribers found when you select all the campaigns is big and the server is getting a timeout. Please try to increase the PHP maximum_execution_time or the memory_limit
 

Eric535

Member
Hello!
It seems that the number of subscribers found when you select all the campaigns is big and the server is getting a timeout. Please try to increase the PHP maximum_execution_time or the memory_limit

Thanks. But where I do that? I think I have done that in wordpress but not mailwizz.
 

Eric535

Member
So as a reference I went to

backend/index.php/misc/phpinfo

Then I changed

max_execution_time = 30

to

max_execution_time = 120

Ran the filter and it still didnt work.

I changed
memory_limit = 256

to

memory_limit = 512

and it crashed my server so i disabled it.
 

ghimes

Member
Staff member Support Staff
Hello,
This settings depends also on your available resources also. You said that setting the memory to 512 crashed your server, that makes me wonder how much memory do you have available?
Bottom line, it seems that if the filter is retrieving less records, everything is fine. The page crushes if the result set is big, that lead to the conclusion that is a server setting (maybe resource limitation) related problem.

Cosmin
 

twisted1919

Administrator
Staff member
Dont know if Im in the right file. When I renamed mysqld.cnf to mysqld-OLD.cnf and restart the mysql server MW didnt crash.
It shouldn't, but now do you have your mysql configuration file with proper values in it ?

Its been a while since my last response. I still havent heard from you.
Sorry for that, lots going on with mailwizz development, we're all working there for now.
 

Eric535

Member
I put this at the bottom of my mysqld.cnf file

Code:
# MySQL / MariaDB Optimizations recommended for Mailwizz
innodb_buffer_pool_size = 5734
innodb_flush_log_at_trx_commit = 2
max_connections = 500

# End Mailwizzz
 

Eric535

Member
@twisted1919

Well...

Those are bytes... so i think what you did, you made things worse :)
Oh. So your saying i should of put the M behind it? Like 5734M? LOL

They have to go in the [mysqld] section of that file.
You can put the entire file here if you wish and i'll tell you where to add the config.[/QUOTE]

Here is what I have now

Code:
#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

[mysqld_safe]
socket        = /var/run/mysqld/mysqld.sock
nice        = 0

[mysqld]
#
# * Basic Settings
#
user        = mysql
pid-file    = /var/run/mysqld/mysqld.pid
socket        = /var/run/mysqld/mysqld.sock
port        = 3306
basedir        = /usr
datadir        = /var/lib/mysql
tmpdir        = /tmp
lc-messages-dir    = /usr/share/mysql
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address        = 127.0.0.1
#
# * Fine Tuning
#
key_buffer_size        = 16M
max_allowed_packet    = 16M
thread_stack        = 192K
thread_cache_size       = 8
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover-options  = BACKUP
#max_connections        = 100
#table_cache            = 64
#thread_concurrency     = 10
#
# * Query Cache Configuration
#
query_cache_limit    = 1M
query_cache_size        = 16M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
# As of 5.1 you can enable the log at runtime!
#general_log_file        = /var/log/mysql/mysql.log
#general_log             = 1
#
# Error log - should be very few entries.
#
log_error = /var/log/mysql/error.log
#
# Here you can see queries with especially long duration
#log_slow_queries    = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
#       other settings you may need to change.
#server-id        = 1
#log_bin            = /var/log/mysql/mysql-bin.log
expire_logs_days    = 10
max_binlog_size   = 100M
#binlog_do_db        = include_database_name
#binlog_ignore_db    = include_database_name
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem

# MySQL / MariaDB Optimizations recommended for Mailwizz
innodb_buffer_pool_size = 5734
innodb_flush_log_at_trx_commit = 2
max_connections = 500

# End Mailwizzz
 
Top