List-unsubscribe Header

i'm trying to add the List-Unsubscribe header to all my delivering servers so I add List-Unsubscribe as header name and <[UNSUBSCRIBE_URL]> as content but when i Save it gets deleted.

Can you please fix this. this tag is really important to enhanced deliverability and as I matter of fact - imo - makes my mail looks more professional and legit.

thanks ;)
This header is added by mailwizz automatically anyway, that's the reason why you can't save it, because is a core header added already by the app.
Thanks for your reply! Wow, it's true. Why then Gmail in not honoring this header and showing it like this?

Is there a way to do so?
Last edited:
PS: but I think there's a a problem. Here's my List-Unsubscribe header.

List-Unsubscribe: <>,
<mailto:[LIST_UNSUBSCRIBE_EMAIL]?subject=Unsubscribe&body=Please unsubscribe
me from Newsletter di Sebastian list.>

As you can see t he [LIST_UNSUBSCRIBE_EMAIL] is there, and not replaced. Should I do something on my List's settings or is this somekind of bug?
Many. For that email MW used SendGrid. If you want I can send you a complete email header

UPDATE: same thing with MailGun
Last edited:
By the way, as I'm working on it, this is the actual List-Uscibscribe header sent via an ElasticMail server:


WTF is this???? :D :D
It looks like there is no trace of the [UNSUBSCRIBE_URL] at all in this email.
No it's fine, i just remembered those headers are not parsed for web api's because some of these apis don't allow setting custom headers.
You can unzip attached and move the php files inside apps/common/models to fix this issue for now.
Thanks for reporting it though, nice find.


    17.5 KB · Views: 68
No problem, I'm very happy to help. I really love MW and I'll do anything to help you in the development.

Great!! Now those headers works and the unsubscribe email is replaced. Thanks a lot.

(but still can't see the "unsubscribe" link in Gmail. However it look like only Facebook has that special link.)
Google does a sending scoring before it will show various options such as that unsubscribe link. Most likely you are not there yet

Wait. Are you telling me I have to earn the right to be deemed a "credible sender" (in the eyes of Google) before Gmail will display my unsubscribe link? That seems a little backward.
Often their "unsubscribe" link are fake one which, instead, confirms that the victim's address is active.
Well there you go. I hadn't considered that. Just starting to find my way around the logistics of email delivery. Learning a lot here for sure.
I'm bring this thread up again as iv noticed something weird when sending some test emails out via ElasticMail.

X-Report-Abuse: Please report abuse for this campaign here:

How come in the headers that those 2 are showing like that, yet the EBS header displays fine as the URL, where as List-Unsubscribe and X-Report-Abuse is encoded?

I've also asked ElasticMail support but they are asking me why i want it changing, I've told them i want the URLs to display like how the EBS header is showing but still not heard anything back from them yet. So i dont know if this is an issue within MailWizz or ElasticMail. It only happens when i send emails via them.
Looking in the code i see this:
// since
$listUnsubscribeHeaderEmail = $customer->getGroupOption('campaigns.list_unsubscribe_header_email', '');
if (empty($listUnsubscribeHeaderEmail) && !empty($campaign->reply_to)) {
    $listUnsubscribeHeaderEmail = $campaign->reply_to;
if (!empty($listUnsubscribeHeaderEmail)) {
    $_subject = sprintf('Campaign-Uid:%s / Subscriber-Uid:%s - Unsubscribe request', $campaign->campaign_uid, $subscriber->subscriber_uid);
    $_body    = 'Please unsubscribe me!';
    $mailToUnsubscribeHeader    = sprintf(', <mailto:%s?subject=%s&body=%s>', $listUnsubscribeHeaderEmail, $_subject, $_body);
    $listUnsubscribeHeaderValue .= $mailToUnsubscribeHeader;
So, if you do not set a REPLY-TO address in your server/campaigns and you keep the "List unsubscribe header email" empty from /backend/index.php/settings/customers/campaigns then the email won't be added, just the url ;)