IP address using additional headers

Paul Smith

New Member
Hi

I have a dedicated IP address from spark post and you have said that it can be added into the additional headers of the server setup

I do not know how to work out what to put into it to make it work Spark post are telling me this

so for SMTP you need to ensure you are adding the following information…
X-MSYS-API: { “options” : { “ip_pool” : “ip_pool1” } }

What i don't know is exactly what do i put into the two header fields as per the attached image. This is what Spark post have given me
IP Pool Name: ip_pool1
IP Address: XX.XX.XX.XXX
Could you help with exactly what should be in the fields please

FYI i have a valid renewed support subscription but the forum is saying i don't
Thanks
Paul
 

Attachments

  • header.png
    header.png
    9 KB · Views: 11

Paul Smith

New Member
Hi I have found out that the correct code to add is
{"options":{"ip_pool" : "ip_pool1"}} but when i add this into the header field it removes the colons so it is then changed to this
{"options" {"ip_pool" "ip_pool1"}} and doesnt work.

How can i stop it stripping out the colons : when i press save
 

Paul Smith

New Member
Thanks, Any chance of getting the fix, without being able to use a dedicated IP I'm sending through ip's on blacklists and it's taking a toll on my open rate
 

twisted1919

Administrator
Staff member
@Paul Smith - The fix is simple, open the file apps/common/models/DeliveryServer.php and search for:
PHP:
$value  = preg_replace('/:/', '', trim($header['value']));
And make it:
PHP:
$value  = trim($header['value']);
It's around line 1269.
 
Top