Installing Mailwizz application on CentOS 7

theStreetRepz

New Member
I'm trying to install Mailwizz for a client. I've configured the DigitalOcean droplet using CentOS 7 and it has been configured to use PHP7, mysql (mariadb) and apache.

Bash:
[root@mailwizz ~]# mysql --version
mysql  Ver 15.1 Distrib 5.5.64-MariaDB, for Linux (x86_64) using readline 5.1

[root@mailwizz ~]# php -v
PHP 7.4.3 (cli) (built: Feb 18 2020 11:53:05) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
After installing the software, i'm getting success on the requirements page
Screen Shot 2020-03-25 at 9.52.26 PM.png

But upon proceeding to the file system permissions page, i am greeted with an error:
Screen Shot 2020-03-25 at 9.53.47 PM.png

I've logged back on to the server and ran the requested commands and see a successful out put of the updated directory permissions:
Bash:
[root@mailwizz ~]# /var/www/html/apps/console/commands/shell/set-dir-perms
Setting proper permissions for directories...
chmod -R 0777 /var/www/html/apps/common/config -> done.
chmod -R 0777 /var/www/html/apps/common/runtime -> done.
chmod -R 0777 /var/www/html/backend/assets/cache -> done.
chmod -R 0777 /var/www/html/customer/assets/cache -> done.
chmod -R 0777 /var/www/html/frontend/assets/cache -> done.
chmod -R 0777 /var/www/html/frontend/assets/files -> done.
chmod -R 0777 /var/www/html/frontend/assets/gallery -> done.
chmod -R 0777 /var/www/html/apps/extensions -> done.
DONE!
I have even verified the directories themselves as well as changed the directory ownership from root to apache AND restarted both the apache service as well as the VPS (droplet):
Bash:
[root@mailwizz html]# ls -l apps/common/ | grep 'config\|runtime'
drwxrwxrwx.  2 apache apache  129 Mar 15 23:41 config
drwxrwxrwx.  2 apache apache   24 Mar 15 23:41 runtime

[root@mailwizz html]# ls -l backend/assets/ | grep cache
drwxrwxrwx. 2 apache apache   24 Mar 15 23:41 cache

[root@mailwizz html]# ls -l customer/assets/ | grep cache
drwxrwxrwx. 2 apache apache   24 Mar 15 23:41 cache

[root@mailwizz html]# ls -l frontend/assets/ | grep 'cache\|files\|gallery'
drwxrwxrwx. 2 apache apache  24 Mar 15 23:41 cache
drwxrwxrwx. 3 apache apache 104 Mar 15 23:41 files
drwxrwxrwx. 2 apache apache  24 Mar 15 23:41 gallery

[root@mailwizz html]# ls -l apps | grep extensions
drwxrwxrwx.  2 apache apache    6 Mar 15 23:40 extensions
I'm unsure of where to proceed from here. Please advise.
 

theStreetRepz

New Member
@twisted1919 - thank you for your response. I have modified the script making both changes but am still getting the permissions errors on the permissions page.

Bash:
[root@mailwizz opt]# vim /var/www/html/apps/console/commands/shell/set-dir-perms

[root@mailwizz opt]# /var/www/html/apps/console/commands/shell/set-dir-perms
Setting proper permissions for directories...
chmod -R 0755 /var/www/html/apps/common/config -> done.
chmod -R 0755 /var/www/html/apps/common/runtime -> done.
chmod -R 0755 /var/www/html/backend/assets/cache -> done.
chmod -R 0755 /var/www/html/customer/assets/cache -> done.
chmod -R 0755 /var/www/html/frontend/assets/cache -> done.
chmod -R 0755 /var/www/html/frontend/assets/files -> done.
chmod -R 0755 /var/www/html/frontend/assets/gallery -> done.
chmod -R 0755 /var/www/html/apps/extensions -> done.
DONE!

[root@mailwizz opt]# systemctl restart httpd

[root@mailwizz opt]# !vim
vim /var/www/html/apps/console/commands/shell/set-dir-perms

[root@mailwizz opt]# /var/www/html/apps/console/commands/shell/set-dir-perms
Setting proper permissions for directories...
chmod -R 0775 /var/www/html/apps/common/config -> done.
chmod -R 0775 /var/www/html/apps/common/runtime -> done.
chmod -R 0775 /var/www/html/backend/assets/cache -> done.
chmod -R 0775 /var/www/html/customer/assets/cache -> done.
chmod -R 0775 /var/www/html/frontend/assets/cache -> done.
chmod -R 0775 /var/www/html/frontend/assets/files -> done.
chmod -R 0775 /var/www/html/frontend/assets/gallery -> done.
chmod -R 0775 /var/www/html/apps/extensions -> done.
DONE!

[root@mailwizz opt]# systemctl restart httpd
Output of the part of the script that changes the file permissions:
Bash:
for i in "${PATHS[@]}"
do
    printf "%s" "chmod -R 0775 $i -> "
    chmod -R 0775 "$i"
    printf "%s\n" "done."
done
 

twisted1919

Administrator
Staff member
Could be some aggressive cache going on?
Can you open a ticket and include url to install and maybe ftp access so we can take a look?
 

theStreetRepz

New Member
@twisted1919 would it be possible to instead grant you SFTP access. i'd rather not install FTP and open up those ports, if i don't have to. If you'd like to private message me your public key, i can add it to known_hosts and that should grant you similar access as would have been granted using.

I can also send you the URL information as a response to your private message as well
 
Top